Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 06-30-2017, 01:37 AM   #1
Registered User
 
Join Date: Jun 2017
Posts: 1
Unscrupulous or just a glitch?

So, I've been fighting to get all my readiness codes for smog in Ca. Driven 600 mi each on 2 resets. All 7/8 go ready except SAI. Many of you have told me it's got to be driven. I would think after 600 mi that I would have completed the drive cycle many times. Today, I visit a Indy Porsche guy and he told me he would connect to their Scanner and tell me what didn't go ready. I obliged because I thought maybe he could confirm whether my cheapy HF was accurate or not. After he connects his Hi tech scanner tells me that 5 are not ready. I asked him if he had done a reset as I had confirmed on my scanner before going to him that only 1 SAI was not ready. He said no. Could this actually happen just by connecting his scanner to acquire my data? Do you think I got scammed by these guys? After he scans my engine only 3/8 were ready. I've got to go through the entire process again. Frustrated. Am I over thinking these guys? Please advise.

My cats and O2 sensors were not ready after they put their reader on as well as SAI

KevinBarth is offline   Reply With Quote
Old 06-30-2017, 02:53 AM   #2
Registered User
 
Join Date: Sep 2016
Location: Stow, MA
Posts: 915
Garage
The scanner cannot set codes. It can read them and clear them.
__________________
2004 Boxster S Silver - FUNTOY
2002 Boxster Base Guardsy Red - FUNBOX
1987 Caterham Super 7 1700 Supersprint
2009 Mercedes Benz CLK 350 convertible
1941 Dodge Luxury Liner Coupe
Anker is offline   Reply With Quote
Old 06-30-2017, 03:40 AM   #3
Registered User
 
steved0x's Avatar
 
Join Date: Dec 2012
Location: FL
Posts: 4,105
But if you clear codes it resets all the readiness flags and the car has to go through one or more drive cycles before it marks them as ready, while others are marked ready right away (I think)

We were just shopping for a used car for my stepdaughter and many of the cars did not have all the readiness flags set, probably because of dead batteries and jump starts...

Search for drive cycle on this forum, there is a description somewhere, and that may help you get them all set.

Are you getting any DTC or just the readiness flags not set.

Btw I am using a $10 elm.bluetooth dongle, yours should be ok.
steved0x is offline   Reply With Quote
Old 06-30-2017, 08:33 AM   #4
Registered User
 
Join Date: Feb 2005
Location: It's a kind of magic.....
Posts: 5,558
Quote:
Originally Posted by KevinBarth View Post
So, I've been fighting to get all my readiness codes for smog in Ca. Driven 600 mi each on 2 resets. All 7/8 go ready except SAI. Many of you have told me it's got to be driven. I would think after 600 mi that I would have completed the drive cycle many times. Today, I visit a Indy Porsche guy and he told me he would connect to their Scanner and tell me what didn't go ready. I obliged because I thought maybe he could confirm whether my cheapy HF was accurate or not. After he connects his Hi tech scanner tells me that 5 are not ready. I asked him if he had done a reset as I had confirmed on my scanner before going to him that only 1 SAI was not ready. He said no. Could this actually happen just by connecting his scanner to acquire my data? Do you think I got scammed by these guys? After he scans my engine only 3/8 were ready. I've got to go through the entire process again. Frustrated. Am I over thinking these guys? Please advise.

My cats and O2 sensors were not ready after they put their reader on as well as SAI
Just be aware that clearing codes does not solve the problems, if a fault triggered the code(s), and has not been repaired, the codes will come back. You need to get the car scanned with a Porsche specific scan tool (PSTII, PIWIS, Durametric) and record the codes as they will give you a starting point for fixing what is wrong.
__________________
Anything really new is invented only in one’s youth. Later, one becomes more experienced, more famous – and more stupid.” - Albert Einstein
JFP in PA is offline   Reply With Quote
Old 07-01-2017, 07:25 PM   #5
Registered User
 
Join Date: Dec 2014
Location: Pasadena
Posts: 257
Don't give up, I had the same issue 7/8 ready except for SAI. When I took it to a Indy they reset it as well but claimed they didn't. I drove in as I checked with my cheapy code reader just prior and drove almost 500 mi. Frustrated, I finally came across a thread where a guy did a cold start and immediately reved to 2700/2800 rpm during the entire 90 Sec during a cold start. He claimed it worked. Being the skeptic but having nothing much to loose at this point as my emission check was 2 mo overdue I tried it in the evening after it sat all day and without driving it it went ready right in the garage. Next day off to Smog check and big relief! So this driving cycle I don't give much credence to.
Lapister is offline   Reply With Quote
Old 07-02-2017, 06:07 AM   #6
Registered User
 
Join Date: Sep 2016
Location: Stow, MA
Posts: 915
Garage
Quote:
Originally Posted by Lapister View Post
Don't give up, I had the same issue 7/8 ready except for SAI. When I took it to a Indy they reset it as well but claimed they didn't. I drove in as I checked with my cheapy code reader just prior and drove almost 500 mi. Frustrated, I finally came across a thread where a guy did a cold start and immediately reved to 2700/2800 rpm during the entire 90 Sec during a cold start. He claimed it worked. Being the skeptic but having nothing much to loose at this point as my emission check was 2 mo overdue I tried it in the evening after it sat all day and without driving it it went ready right in the garage. Next day off to Smog check and big relief! So this driving cycle I don't give much credence to.
Follow this advice at you own peril!
__________________
2004 Boxster S Silver - FUNTOY
2002 Boxster Base Guardsy Red - FUNBOX
1987 Caterham Super 7 1700 Supersprint
2009 Mercedes Benz CLK 350 convertible
1941 Dodge Luxury Liner Coupe
Anker is offline   Reply With Quote
Old 07-02-2017, 06:56 AM   #7
Registered User
 
GTA_G20's Avatar
 
Join Date: Jan 2008
Location: St Catherines, Ontario
Posts: 422
Something tells me your SAI is unplugged.

Reason being. I was having SAI codes with my former '97. I erased the code several.times attempting to make it pass emissions. Issue is it's a two ignition fault. Meaning with two starts of the car after the second cold start that system is checked and if issue CEL with the SAI code is triggered. Check to see it's plugged in

GTA_G20 is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 12:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page