Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Performance and Technical chat

Reply
 
LinkBack Thread Tools Display Modes
Old 07-09-2015, 09:47 PM   #1
Registered User
 
Join Date: Jun 2015
Location: Granada hills, ca
Posts: 11
Need help. Have a solid coolant light and i cant figure it out..

1999 2.5 has a solid coolant light on. Left it on a revved it for 2 min at 3k rpm amd left it on for 10 mim but the temp didnt fluctuate or move at all. Coolant level was normal i added a cup of water and it just spit out through the rear passenger wheel area(assuming its the overflow?). Should i replace the coolant sensor? I just want to get that light off and make sure im not overheating later when i start driving it to work again. Any help is greatly appreciated

When my front end accident occured my coolant light turned on. I assumed my radiator took a hit but it looks totally fine i brought it to my uncles shop he said it appeared okay as well. Is there a sensor or something that might have triggered it? Im gonna fill it up with coolant to see if the light goes away or if it leaks somewhere else

Keanu is offline   Reply With Quote
Old 07-11-2015, 12:44 PM   #2
Registered User
 
woodsman's Avatar
 
Join Date: Feb 2013
Location: Land of naught
Posts: 1,302
You could check the temp in the overflow reservoir with a thermometer. Eventually the fans should come on to lower the coolant's temp. You've got to make sure the engine's being cooled since these engines are extremely sensitive to overheating. Use the 'search' function and keep on it or you'll find you have an intermix problem...
__________________
Death is certain, life is not.
woodsman is offline   Reply With Quote
Old 07-11-2015, 06:09 PM   #3
Registered User
 
thom4782's Avatar
 
Join Date: Sep 2010
Location: Foster City CA
Posts: 1,086
What does the temperature gauge read when the coolant light is on? For example, is it always on regardless of what the gauge says or does it come on at some number on the gauge.

Your saying that the coolant level in the tank is normal suggests either the sensor is bad or coolant isn't circulating. If the gauge is pegged on a high number, then it would seem more likely that coolant isn't flowing. If the light is on all the time, then suspect a bad sensor.

If you're concerned about leaks, have the coolant system pressure tested.
thom4782 is offline   Reply With Quote
Old 07-12-2015, 10:09 AM   #4
Registered User
 
Join Date: Aug 2005
Location: Sanford NC
Posts: 2,376
Fans operating? Since there was front end repair ....

Water Pump operating?

Sensor? Wiring?

Last edited by mikefocke; 07-12-2015 at 05:38 PM.
mikefocke is offline   Reply With Quote
Old 07-12-2015, 10:38 AM   #5
Registered User
 
Join Date: Jun 2015
Location: Granada hills, ca
Posts: 11
Thanks for all the feed back ive been doing a lot of reading but everyone seems to have blinking lights.

As soon as i turn on the car the light is on and temperatures stay a little past the halfway mark buts its been like that since i bought it. It has been pressure tested and no leaks every looks good.. The fans are operating as they should and how do i test the water pump? Whats the best way to check if its recirculating?

Last edited by Keanu; 07-12-2015 at 10:42 AM.
Keanu is offline   Reply With Quote
Old 07-12-2015, 10:39 AM   #6
Registered User
 
Join Date: Jun 2015
Location: Granada hills, ca
Posts: 11
Is the sensor i should be replacing? 1997-2006 Porsche Boxster Coolant Level Sensor - Cooling System - Original Equipment 97-06 Boxster Coolant Level Sensor - 131-01090203 - PartsGeek
Keanu is offline   Reply With Quote
Old 07-12-2015, 03:23 PM   #7
Registered User
 
thom4782's Avatar
 
Join Date: Sep 2010
Location: Foster City CA
Posts: 1,086
If it is a sensor, it's most like the coolant temperature sensor. Search Pelican Parts for it.

That said, two symptoms seem to conflict with one another. The gauge reads normal, but the temperature light is on. If it were a bad sensor, one would expect the light to blink - slow for bad level sensor; fast for bad temperature sensor.
thom4782 is offline   Reply With Quote
Old 07-12-2015, 05:40 PM   #8
Registered User
 
Join Date: Aug 2005
Location: Sanford NC
Posts: 2,376
Has the temp light ever operated "correctly" since the front end work? I'm thinking the coolant might have been refilled but the system wasn't successfully "burped" so there is air in the system at an inconvenient place.
mikefocke is offline   Reply With Quote
Old 07-21-2015, 09:07 AM   #9
Registered User
 
Join Date: Jun 2015
Location: Granada hills, ca
Posts: 11
Yeahi just had it bled profiessionally this time with new porsche coolant still no luck. Im still waiting on on the cts to come in really hoping thats it!

Keanu is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 07:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page