Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Performance and Technical chat

Reply
 
LinkBack Thread Tools Display Modes
Old 10-18-2018, 12:00 PM   #1
Registered User
 
Join Date: Sep 2015
Location: St. Petersburg, Florida
Posts: 220
Installed New Gauge Cluster - Check Engine Light On

Greetings,

Just hooked up a new (used) cluster in my Boxster, and while everything seems to be working fine, the check engine light is on. The light was not on before my old cluster stopped working.

Does something require a reset?

Thanks!
__________________
1998 Porsche Boxster - Ocean Jade Metallic

1985 Porsche Carrera Targa - Guards Red

1978 Porsche 911SC Euro Non-Sunroof - Grand Prix White
Seadweller is offline   Reply With Quote
Old 10-19-2018, 08:50 AM   #2
Registered User
 
redciv1's Avatar
 
Join Date: Jun 2014
Location: Dacula, Georgia
Posts: 237
Hello Sea. I did not have a check engine light that appeared with my new cluster. Have you had a chance to pull the code? Could be irony that some trips light when new cluster put in.
redciv1 is offline   Reply With Quote
Old 10-19-2018, 09:11 AM   #3
Registered User
 
Join Date: Sep 2015
Location: St. Petersburg, Florida
Posts: 220
Not yet, I actually brought the replacement cluster to my speedo guy so he can use as much of my original cluster as possible. Once I get that back in the car, I need to bring it to my indy for an oil/filter change and motor mount replacement, so I'll have them check the code at that time. I'm also going to try disconnecting the battery.
__________________
1998 Porsche Boxster - Ocean Jade Metallic

1985 Porsche Carrera Targa - Guards Red

1978 Porsche 911SC Euro Non-Sunroof - Grand Prix White
Seadweller is offline   Reply With Quote
Old 10-19-2018, 10:26 AM   #4
Custom User Title Here
 
particlewave's Avatar
 
Join Date: Mar 2012
Location: KC
Posts: 5,665
Garage
Maybe the CEL bulb in your old cluster was just burnt out.
particlewave is offline   Reply With Quote
Old 10-19-2018, 10:29 AM   #5
Registered User
 
Join Date: Sep 2015
Location: St. Petersburg, Florida
Posts: 220
Quote:
Originally Posted by particlewave View Post
Maybe the CEL bulb in your old cluster was just burnt out.
That's certainly a possibility, and something I'll definitely check.
__________________
1998 Porsche Boxster - Ocean Jade Metallic

1985 Porsche Carrera Targa - Guards Red

1978 Porsche 911SC Euro Non-Sunroof - Grand Prix White
Seadweller is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 03:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page