Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Performance and Technical chat

Reply
 
LinkBack Thread Tools Display Modes
Old 04-13-2018, 05:42 PM   #1
Registered User
 
jsceash's Avatar
 
Join Date: Aug 2009
Location: PA
Posts: 1,331
Garage
Clutch what did I do

I just replace my clutch and axles. bled the slave cylinder for and hour I can't get the pedal to pop back out the whole way. Pull the transmission again to make sure I didnt pop the arm off the pivot or disconnect something. Put it all back together again and I still have to pop the pedal up. New Spec 1 clutch and pressure plate replaced an old Spec clutch.
__________________
2003 Boxster 3.6 LN Nickies Black
NHP exhaust, 987 Intake, IPD Plenum, 74 MM Throtle body, L&N Pan Extension, L&N IMS, RSS Underdrive pulley, Recaro Pole Position seats, Accusump, Remote filter, Softronics Flashed ECU, GSR electric power steering pump Kit. GT3 control arm, KSport coil overs
jsceash is offline   Reply With Quote
Old 04-13-2018, 06:03 PM   #2
Registered User
 
Join Date: Jul 2005
Location: MA
Posts: 741
I had the exact same symptoms. Replaced the slave thinking that was the problem but it turned out to be a cracked (plastic) clutch line that was leaking behind my fender. There’s an an upgraded version, IIRC.

More here: https://www.renntech.org/forums/topic/38449-small-puncture-in-clutch-line/
__________________
98 Arena Red 986

2010 e61 535 "TTWAGON"

Last edited by Stroked & Blown; 04-13-2018 at 06:06 PM.
Stroked & Blown is offline   Reply With Quote
Old 04-13-2018, 06:03 PM   #3
Registered User
 
Join Date: Sep 2016
Location: Stow, MA
Posts: 676
Garage
Is it just a fraction of an inch or is it a lot more? Your clutch assist spring may be broken if its just a little bit.
__________________
2004 Boxster S Silver - FUNTOY
2002 Boxster Base Guardsy Red - FUNBOX
2009 Mercedes Benz CLK 350 convertible
2015 Chevrolet Volt
1941 Dodge Luxury Liner Coupe
Anker is offline   Reply With Quote
Old 04-13-2018, 06:13 PM   #4
Registered User
 
jsceash's Avatar
 
Join Date: Aug 2009
Location: PA
Posts: 1,331
Garage
Quote:
Originally Posted by Anker View Post
Is it just a fraction of an inch or is it a lot more? Your clutch assist spring may be broken if its just a little bit.
Comes up about 1/2 way then stops unless I Put my foot under it and lift. Almost like it catching.
__________________
2003 Boxster 3.6 LN Nickies Black
NHP exhaust, 987 Intake, IPD Plenum, 74 MM Throtle body, L&N Pan Extension, L&N IMS, RSS Underdrive pulley, Recaro Pole Position seats, Accusump, Remote filter, Softronics Flashed ECU, GSR electric power steering pump Kit. GT3 control arm, KSport coil overs
jsceash is offline   Reply With Quote
Old 04-14-2018, 03:05 AM   #5
Registered User
 
Join Date: Nov 2010
Location: France
Posts: 32
I agree, Your clutch assist spring may be broken, an easy ckeck above the pedal.
philou320 is offline   Reply With Quote
Old 04-14-2018, 04:52 AM   #6
still plays with cars...
 
BoxsterSteve's Avatar
 
Join Date: May 2011
Location: Baden, ON, Canada
Posts: 1,050
Garage
Quote:
Originally Posted by jsceash View Post
Comes up about 1/2 way then stops unless I Put my foot under it and lift. Almost like it catching.
Sounds like what mine did after a brake line flush.
My indie rebled the clutch line and all was good.
__________________
Six speed 2000 Boxster S
Arctic Silver on Metropol Blue | Arctic Silver console, spoiler frame & bumperettes | Crios mod | Technobrace | RoboTop module & modified convertible top relay for one-touch roof operation
BoxsterSteve is offline   Reply With Quote
Old 04-14-2018, 05:32 AM   #7
Registered User
 
Join Date: Jul 2005
Location: MA
Posts: 741
If it ends up being the spring, I have a bunch of extra McMaster “upgraded” springs & can send you one for the cost of postage.
__________________
98 Arena Red 986

2010 e61 535 "TTWAGON"
Stroked & Blown is offline   Reply With Quote
Old 04-14-2018, 10:18 AM   #8
Registered User
 
jsceash's Avatar
 
Join Date: Aug 2009
Location: PA
Posts: 1,331
Garage
OK I changed the brake pads and flushed the lines another time problem resolved. Thanks everyone for your replies, I should have done this first.
__________________
2003 Boxster 3.6 LN Nickies Black
NHP exhaust, 987 Intake, IPD Plenum, 74 MM Throtle body, L&N Pan Extension, L&N IMS, RSS Underdrive pulley, Recaro Pole Position seats, Accusump, Remote filter, Softronics Flashed ECU, GSR electric power steering pump Kit. GT3 control arm, KSport coil overs
jsceash is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 12:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page