Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Performance and Technical chat

Reply
 
LinkBack Thread Tools Display Modes
Old 10-26-2014, 12:12 AM   #1
Registered User
 
Join Date: Aug 2014
Location: Northern California
Posts: 129
Beater Boxster Climate Fan Motor...

I was able to score a set of sun visors and a climate controller today. The visors went on without a hitch, went up, went down, lights worked fine.

Installed the climate controller. For the first time I was able to see what the buttons did. My old display was so bad I couldn't read anything. I was feeling good until I tried manually increasing the fan speed and could hear a faint repetative thump inside the dash. My thoughts either the fan blades are hitting an obstruction or the motor is toast.

I plan on removing the motor assembly and bench testing it. Any advise before I do this? I've read on the internet that somehow a foreign object made its way pass the pollen filter. I can check that too.

For those of you that have replaced the fan motor, did you remove the passenger seat? I could barely move around when I was checking fuses and relays on the drivers side. I'm not sure I can manuever underneath the dash without making more room

As always any input would be greatly appreciated!
Cebu is offline   Reply With Quote
Old 10-26-2014, 08:57 AM   #2
Registered User
 
Join Date: Jan 2007
Location: BC
Posts: 1,256
Is this the first time the fan has been working? If not, the question is why it would start doing this with a different controller. I can't imagine why a controller that's not the right part number for your car would create the sort of mechanical noise you're describing, but I suppose it may be possible.

BTW, there are cheap rebuild kits for controller screens that are very good. I've done it myself.
__________________
2001 Boxster, 5 spd, Seal Grey
clickman is offline   Reply With Quote
Old 10-26-2014, 05:49 PM   #3
Registered User
 
Join Date: Aug 2014
Location: Northern California
Posts: 129
The original climate controller display was not viewable. I would assume I was increasing or decreasing fan speed by using the -/+ buttons. The noise coming from the dash is the same as before. Strangely enough the repetition of the sound never increased or decreased.

The newly installed controller is in pristine condition. My old buttons would actually stick and not release without some jiggling and coaxing. I think liquid must have spilled on the face panel since the cupholder used to be on top of the console (I've since removed it completely).

I've seen the rebuild kits online but since the seller sold me the whole controller for about the same price I gambled and went with the seller. I lucked out.

Thank you for the feedback, regards.

Quote:
Originally Posted by clickman View Post
Is this the first time the fan has been working? If not, the question is why it would start doing this with a different controller. I can't imagine why a controller that's not the right part number for your car would create the sort of mechanical noise you're describing, but I suppose it may be possible.

BTW, there are cheap rebuild kits for controller screens that are very good. I've done it myself.
Cebu is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 08:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page