Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Performance and Technical chat

Reply
 
LinkBack Thread Tools Display Modes
Old 08-23-2013, 03:39 PM   #1
Registered User
 
Join Date: Aug 2013
Location: Fort Bragg NC
Posts: 5
Digital speedometer stopped working

Hello Everybody!
I'm hoping there is somebody here that can give me some insight as to why my digital speedometer has stopped working. I purchased a 99 metallic zenith blue boxster when returned from afghanistan. It only has 32000 miles on it and after a year of driving, it's starting to act up. About 2 weeks ago I got in my car to drive home and just as i left the parking lot I noticed that the digi speedo, odometer and trip odometer had all gone blank. I was able to see the orange back light but just not able to see any readings. After some surfing on the ole interweb I came across the fuse diagrams and checked my fuses B1, B10, and i think it was also E1. Everything was good so i put the key in the ignition and turned it over to see if it was working. EVERYTHING WENT DEAD! Now both the analog and digital units were not working, no fuel gauge,temp gauge,tachometer. Just the little red light telling me i needed fuel was working. I had NO DASH LIGHTS illuminating the cluster. All the trouble indicators would light up when you started the car but they didnt stay on so at least they were working. I made an appointment with the local Porsche dealer and took it in for a diagnostic praying to every god it was a blown relay or something small. He calls me the next day and tells me that my entire cluster has gone out and i need to replace it. He can order one and it will cost me $3000 plus labor. He said they inspected the pins and my cluster was getting power but it was just not working. I payed the $150 for the bad news diagnostic and drove it home. This being my only vehicle i kept driving it to work and the other day as i pulled in and turned the ignition off the Porsche God must have heard my prayers because Everything came back on but it was in KMPH setting and odometer read 999999. It's stayed on for a few days now and yesterday the digi displays went blank again but my analogs work. Obviously my cluster isn't dead theres a short somewhere, maybe in the ignition some where since thats when it started working again was when i turned off the car. 1999 boxster 5 spd manual.
Army rigger is offline   Reply With Quote
Old 08-23-2013, 03:51 PM   #2
Registered User
 
ccjazz's Avatar
 
Join Date: May 2012
Location: Vancouver Island, Canada
Posts: 205
Garage
I've never had your problem but here's a link to a thread that may be helpful.

Good luck getting everything back

http://986forum.com/forums/general-discussions/45514-odometer-reset.html
__________________
'01 Boxster S (purchased new) triple black, litronics, cruise, heated seats,18's.
ccjazz is offline   Reply With Quote
Old 08-23-2013, 04:31 PM   #3
Registered User
 
Join Date: Aug 2013
Location: Fort Bragg NC
Posts: 5
I read a post by a gentleman named toolpants who said that if you disconnect the neg batt cable, insert ign key, turn to #1 position, apply brakes briefly to drain any residual current, turn off ignition, and reconnect neg batt cable the milage and odometer will reset to prior display. I didnt get around to doing that yet, and now my digital speedometer/odometer display AGAIN will not display anything. Thank you very much for the link and taking your time to point me in a positive direction. I love this car and want to get it back to displaying the MPH.
Army rigger is offline   Reply With Quote
Old 08-23-2013, 04:34 PM   #4
Registered User
 
ccjazz's Avatar
 
Join Date: May 2012
Location: Vancouver Island, Canada
Posts: 205
Garage
You're welcome. I know this problem has come up here before and I'm sure someone with experience will chime in soon.
__________________
'01 Boxster S (purchased new) triple black, litronics, cruise, heated seats,18's.
ccjazz is offline   Reply With Quote
Old 08-23-2013, 04:36 PM   #5
Registered User
 
Join Date: Aug 2013
Location: Fort Bragg NC
Posts: 5
thats the article i read previously! going to try it once this problem is resolved.
Army rigger is offline   Reply With Quote
Old 08-23-2013, 04:38 PM   #6
Registered User
 
Join Date: Aug 2013
Location: Fort Bragg NC
Posts: 5
Why are Porsche's door ding magnets?
Army rigger is offline   Reply With Quote
Old 08-23-2013, 04:38 PM   #7
Registered User
 
Join Date: Dec 2006
Location: Santa Barbara, CA
Posts: 308
I thought I read somewhere in this Forum that the main processor keep track of the mileage and is independent of the instrument cluster logging.
if over some period of time, if the two stored data do not match, bad thing happens... like the car will not start.
it may have been in a thread that replaced boxster instrument cluster with 996 cluster.
sb01box is offline   Reply With Quote
Old 08-23-2013, 04:46 PM   #8
Registered User
 
ccjazz's Avatar
 
Join Date: May 2012
Location: Vancouver Island, Canada
Posts: 205
Garage
When ignition switches go bad they can also cause all sorts of seemingly unrelated problems. Have you had any issues with the ignition lately (key difficult to insert or remove)?
__________________
'01 Boxster S (purchased new) triple black, litronics, cruise, heated seats,18's.

Last edited by ccjazz; 08-23-2013 at 04:47 PM. Reason: bad speller
ccjazz is offline   Reply With Quote
Old 08-24-2013, 04:21 AM   #9
Vista glass
 
Vista glass's Avatar
 
Join Date: Jun 2012
Location: Florida
Posts: 87
Garage
Thank you for your service to our country. The electrical section of the ignition switch is an inexpensive part. The replacement seems to cure a myriad of mysterious electrical problems. If the problem continues that would be a good path to follow. There is an incredible amount of good information on this site. I have researched every issue with the search function, that along with the 101 projects book and forum responses have made me fearless in maintaining, repairing and upgrading my Boxster. Here is a link to the parts for sale to illustrate that clusters are readily available if that truly is the case.

http://986forum.com/forums/boxster-parts-sale-wanted/47673-fs-cluster-surround.html

Please post the resolution of this problem, and once again THANK YOU.
Vista glass is offline   Reply With Quote
Old 08-27-2013, 10:18 AM   #10
Registered User
 
Join Date: Aug 2013
Location: Fort Bragg NC
Posts: 5
I've had no past issues with the ignition what so ever. This is an excellent forum to learn about my vehicle I've discovered. Thanks for the links and knowledge.
Army rigger is offline   Reply With Quote
Old 08-04-2015, 05:42 PM   #11
Registered User
 
Join Date: Nov 2013
Location: Colorado
Posts: 442
Garage
digital speedometer just went out

Actually, I can just faintly see the digital speedometer and outdoor temperature still displaying and changing while the ignition is on and I can see the speed change in accordance with speed, however, it looks like the backlight has burned out in that center digital display area?
j
jdlmodelt is offline   Reply With Quote
Old 08-05-2015, 08:04 AM   #12
Registered User
 
Join Date: Apr 2015
Location: Michigan
Posts: 114
Quote:
Originally Posted by jdlmodelt View Post
Actually, I can just faintly see the digital speedometer and outdoor temperature still displaying and changing while the ignition is on and I can see the speed change in accordance with speed, however, it looks like the backlight has burned out in that center digital display area?
j
Sounds like you found your problem. You may need to do a little minor surgery to get into the cluster to change out the back lighting.

SportsCarLEDs.com Instrument Panel LEDs Kit for the Porsche Carrera 996 & Boxster 986

As a last resort, you could send it to Qmulus to have it repaired (if you don't want to do it yourself). He has done a gauge cluster for me and did an awesome job.
emore93 is offline   Reply With Quote
Old 08-06-2015, 09:46 AM   #13
Custom User Title Here
 
particlewave's Avatar
 
Join Date: Mar 2012
Location: KC
Posts: 5,735
Garage
Quote:
Originally Posted by jdlmodelt View Post
Actually, I can just faintly see the digital speedometer and outdoor temperature still displaying and changing while the ignition is on and I can see the speed change in accordance with speed, however, it looks like the backlight has burned out in that center digital display area?
j
This is a simple bulb change. You'll have to pull the cluster out, but that only takes a few minutes. The bulbs are easily accessible from the back of the cluster (assuming that yours is pre-facelift).

Last edited by particlewave; 08-06-2015 at 09:48 AM.
particlewave is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 03:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page