Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 08-30-2017, 04:52 PM   #1
Registered User
 
Join Date: May 2008
Location: NJ
Posts: 2
Turn signals not working

After hooking up my tire trailer I found my turn signals didn't work. Checked fuses and replaced flasher. Hazards work. A local shop agreed with me it must be the turn signal switch. They sold me a supposedly good used one. However after installation, still no turn signals. Is there any procedure to troubleshoot the pins on the back? Any other possibiliities? It's a 2000 Boxster. Thanks.

nohops is offline   Reply With Quote
Old 08-31-2017, 02:22 PM   #2
Artist, 986S tinkerer
 
NewArt's Avatar
 
Join Date: Aug 2013
Location: Montreal, Canada
Posts: 1,571
Both front and back? Indicator on dash?
__________________
James
2004 986 S
987 air intake TB and plenum, Mantissport 2 litre sump, UDP, Bilstein B6 with H&R lowering spings, re71-rs for track, other stuff.
https://www.youtube.com/user/12shoes2
NewArt is offline   Reply With Quote
Old 08-31-2017, 03:17 PM   #3
Registered User
 
Join Date: Nov 2006
Location: In the garage...
Posts: 1,567
When was the last time you changed your:



Any other odd electrical gremlins of late (hazards are a separate 'circuit' than turn and work independently from ignition switch.)

PS - Find another errrrr a reliable shop who will diagnose the problem and not just have you throw $ at parts recklessly...
__________________
"Cool Prius!"
- Nobody
Burg Boxster is offline   Reply With Quote
Old 08-31-2017, 05:40 PM   #4
Registered User
 
Join Date: May 2008
Location: NJ
Posts: 2
turn signals not working

It's all the lights. No indicator on the dash. Hazards work as there should. No other electrical gremlins. I talked to a mechanic who felt it was the hazard switch, even though the hazards work. I will explore that option. BTW if you don't have a T30 torx to remove the airbag, a 3/16s straight blade screwdriver will work.

nohops is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 11:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page