Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 12-19-2016, 12:03 PM   #1
Registered User
 
Join Date: Dec 2014
Location: Pasadena
Posts: 253
Tip on Secondary Air not ready

For months I've been fighting SAI not going ready and last night it did without driving the car. I've asked this question to many Smog Station owners, the list here and most everyone has stated the car had to be driven in conjunction with the cold start. Well, I'm here to tell you, not so. I've cold started many a times driven over a 1000 mi and it never worked. So, last night I tried a method suggested by someone else on another forum. Cold start the car and immediately rev it up to 2800 or there about with all power on, AC, headlights for the first 2 min of the SAI test. I took a cheapy code reader to it before and during the startup and Wala it went ready and passed Commiefornia smog this morning. Now, I don't know if this method would work if you had other codes not going ready as I assume other readiness factors may have an affect on SAI. Oh what a relief it is.

Lapister is offline   Reply With Quote
Old 12-19-2016, 01:03 PM   #2
Registered User
 
Join Date: May 2014
Location: S.California
Posts: 2,011
SAI Readiness FIX

Thank you for posting this fix that worked for you. So often these threads just die when people find a solution(??) and just never bother posting which of the suggestions we made ,worked. The best part of your fix is Fast ,Simple ,Zero cost !
Now we need to keep linking your Post for future SAI victims to check how often it works. Compared to all the testing,tearing apart and drive cycle stuff ,yours is a much simpler fix!
Can you link the source you mentioned ? I'll run it by the Smog Test Tech at 'work' and post if he has any useful insights based on the source you supply.
Well done on fixing and passing - without spending lots of money!
Gelbster is offline   Reply With Quote
Old 12-19-2016, 10:26 PM   #3
Registered User
 
Join Date: Dec 2014
Location: Pasadena
Posts: 253
Here's the link from which I borrowed a fellow 986 owners tip.https://www.renntech.org/forums/topic/49155-secondary-air-test-readiness-monitor-incomplete/?page=3

On all my cold starts I let the engine idle completely thru the first 2 min of the test. Drove multiple miles and never set. The only difference between him and I is I just reved it to 2800rpms while sitting in the garage.
Lapister is offline   Reply With Quote
Old 12-20-2016, 08:25 AM   #4
Registered User
 
Join Date: May 2014
Location: S.California
Posts: 2,011
Excellent full reporting.It will surely help others in future.Thank you.

Gelbster is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 09:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page