Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 09-20-2019, 07:01 PM   #1
Shacky
 
Join Date: May 2015
Location: Rochester NY
Posts: 184
'99 Boxster Radio not working - fuse is good

Another electrical snafu. My radio isn't working. Checked fuse and it's OK. Mechanic said there might be another fuse on back of radio.

Is this true?

shacky is offline   Reply With Quote
Old 09-20-2019, 11:44 PM   #2
Registered User
 
Cunningr's Avatar
 
Join Date: Mar 2016
Location: Spain
Posts: 893
Check the amp might be a fuse there, or a loose connection.
__________________
2000 Boxster S Ocean Blue Metalic
Cunningr is offline   Reply With Quote
Old 09-21-2019, 04:18 AM   #3
Who's askin'?
 
maytag's Avatar
 
Join Date: Mar 2018
Location: Utah
Posts: 1,923
Is the back lighting coming on at all? Did this just start all the sudden, no warning?

Sent from my SM-G970U using Tapatalk
maytag is online now   Reply With Quote
Old 09-22-2019, 01:56 AM   #4
Shacky
 
Join Date: May 2015
Location: Rochester NY
Posts: 184
Quote:
Originally Posted by maytag View Post
Is the back lighting coming on at all? Did this just start all the sudden, no warning?

Sent from my SM-G970U using Tapatalk
No lighting at all. My tech was trying to track down a wiring problem with cam sensor error and this was likely result of that work.
shacky is offline   Reply With Quote
Old 09-22-2019, 07:33 AM   #5
Custom User Title Here
 
particlewave's Avatar
 
Join Date: Mar 2012
Location: WA
Posts: 6,084
Garage
Quote:
Originally Posted by shacky View Post
Is this true?
Yes.

......
particlewave is offline   Reply With Quote
Old 09-22-2019, 06:03 PM   #6
Shacky
 
Join Date: May 2015
Location: Rochester NY
Posts: 184
What kind of fuse is it?

Also while I have radio out I want to try and use deoxit to get rid of scratchy volume/tuner knobs. Has anyone else done this?
shacky is offline   Reply With Quote
Old 10-01-2019, 07:29 AM   #7
Vza
Registered User
 
Join Date: Oct 2018
Location: Nj
Posts: 61
Yes there is a fuse at the rear of the head unit. I used Deoxit on my knobs and it cured everything. V
Vza is offline   Reply With Quote
Old 10-01-2019, 11:56 AM   #8
Shacky
 
Join Date: May 2015
Location: Rochester NY
Posts: 184
Quote:
Originally Posted by Vza View Post
Yes there is a fuse at the rear of the head unit. I used Deoxit on my knobs and it cured everything. V
Got it out. Fuse looked good but I tried new one just to be sure. That would have been easy. I assume the big red/black strip wire is power? Will look for voltmeter and check it.

How did you get access to Deoxit?
shacky is offline   Reply With Quote
Old 10-01-2019, 12:01 PM   #9
Shacky
 
Join Date: May 2015
Location: Rochester NY
Posts: 184
Are there any other fuses? Amp in frunk?
shacky is offline   Reply With Quote
Old 10-01-2019, 02:18 PM   #10
Registered User
 
Join Date: May 2017
Posts: 55
just the fuse in the panel. Amp wont do anything with the radio until it is on.
__________________
2000 Boxster Tiptronic
Stl-986 is offline   Reply With Quote
Old 10-01-2019, 06:23 PM   #11
Shacky
 
Join Date: May 2015
Location: Rochester NY
Posts: 184
Found volt meter. Iím not getting any reading on red power plug or the switch power - yellow wire.

Any ideas of where to look now?
shacky is offline   Reply With Quote
Old 10-01-2019, 06:31 PM   #12
Registered User
 
Join Date: Oct 2019
Posts: 1
wait and read
__________________
LukQQ.com Poker Ceme DominoQQ
Lukqq is offline   Reply With Quote
Old 10-01-2019, 07:13 PM   #13
Registered User
 
Join Date: May 2017
Posts: 55
did you test the fuse in the panel with a meter? The key is on when you tested the wires at the radio and you tested red to ground, yellow to ground?
__________________
2000 Boxster Tiptronic
Stl-986 is offline   Reply With Quote
Old 10-01-2019, 07:33 PM   #14
Shacky
 
Join Date: May 2015
Location: Rochester NY
Posts: 184
Quote:
Originally Posted by Stl-986 View Post
did you test the fuse in the panel with a meter? The key is on when you tested the wires at the radio and you tested red to ground, yellow to ground?
Yes key on engine running. I stuck ground lead in radio cage. Will check mail fuse again but it was fine as that was first thing I checked.

Radio sleeve in dash is grounded isnít it?
shacky is offline   Reply With Quote
Old 10-02-2019, 12:04 PM   #15
Shacky
 
Join Date: May 2015
Location: Rochester NY
Posts: 184
I had more time and daylight to check today. There are 2 pins on the radio cable that have 13 Vís. So looks like power getting there. Could HU completely die? With fuse not blown - though mechanic may have tried to cover tracks
shacky is offline   Reply With Quote
Old 10-02-2019, 12:55 PM   #16
Registered User
 
Join Date: Sep 2019
Location: Derby. England
Posts: 6
Maybe a little off topic but o you have to have the head unit and cd multi player matched gents? as my multi player sorts the cd's but does not show on radio head display.
phill is offline   Reply With Quote
Old 10-02-2019, 01:18 PM   #17
Registered User
 
Cunningr's Avatar
 
Join Date: Mar 2016
Location: Spain
Posts: 893
Quote:
Originally Posted by phill View Post
Maybe a little off topic but o you have to have the head unit and cd multi player matched gents? as my multi player sorts the cd's but does not show on radio head display.
You might need to activate it on the radio but cant remember how to access the screen. You change to aux or cd i think.
__________________
2000 Boxster S Ocean Blue Metalic
Cunningr is offline   Reply With Quote
Old 10-02-2019, 01:49 PM   #18
Shacky
 
Join Date: May 2015
Location: Rochester NY
Posts: 184
I do not have CD changer. Nothing shows on HU. Are there more than two wires with power to HU?
shacky is offline   Reply With Quote
Old 10-02-2019, 03:48 PM   #19
Registered User
 
Join Date: May 2017
Posts: 55
No. There is constant, switched and ground, that is all you need. If it doesn't turn on and the fuse is good then it's time to replace it with another oem one or aftermarket. If replacing with aftermarket it might be best to take it somewhere and have them do it. If going with oem make sure you get the radio code also and it will be plug & play.
__________________
2000 Boxster Tiptronic
Stl-986 is offline   Reply With Quote
Old 10-02-2019, 07:59 PM   #20
Shacky
 
Join Date: May 2015
Location: Rochester NY
Posts: 184
Quote:
Originally Posted by Stl-986 View Post
No. There is constant, switched and ground, that is all you need. If it doesn't turn on and the fuse is good then it's time to replace it with another oem one or aftermarket. If replacing with aftermarket it might be best to take it somewhere and have them do it. If going with oem make sure you get the radio code also and it will be plug & play.
Ordered Alpine from Crutchfield 😉

shacky is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 02:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page