Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 09-23-2013, 01:05 PM   #1
Registered User
 
Join Date: Sep 2013
Posts: 2
Dash Lights

Hi,

I'm posting on behalf of my uncle who has just purchased a MY02 Porsche boxers S.

It's a great car and I'm very impressed by it but unfortunately there is a problem with the interior lights, mainly the dash lights.

When starting the car the interior dash lights all come on fine. After a couple of minutes all the dash lights go out and stay out. The lights around the centre console screen, rev counter lights and the lights on rotary switch are all affected? The digital area of the dash stays on as does the aircon controls.

Has anyone else experienced this fault? We've checked the fuses and everything is fine as you would expect as the do come on for a short period.....

Any help would be much appreciated! I have tried searching but couldn't find anything specific.

Thanks in advance

James

SC'ed S2000 is offline   Reply With Quote
Old 09-23-2013, 02:44 PM   #2
Registered User
 
Steve Tinker's Avatar
 
Join Date: Dec 2008
Location: Queensland, Australia
Posts: 1,522
The ignition switch has an electrical portion that is prone to give strange symptoms like yours. You can change it out without too much cost / difficulty - use the search function < ignition switch > on the above toolbar and you will get lots of info.....

Pelican Technical Article: Boxster Ignition Switch Replacement - 986 / 987
__________________
2001 Boxster S (triple black). Sleeping easier with LN Engineering/Flat 6 IMS upgrade, low temp thermostat & underspeed pulley.
2001 MV Agusta F4.

Last edited by Steve Tinker; 09-23-2013 at 02:47 PM.
Steve Tinker is offline   Reply With Quote
Old 09-23-2013, 03:09 PM   #3
Need For Speed
 
KRAM36's Avatar
 
Join Date: Feb 2013
Location: Funville
Posts: 2,112
Garage
Pelican Technical Article: Boxster Ignition Switch Replacement - 986 / 987
KRAM36 is offline   Reply With Quote
Old 09-23-2013, 03:37 PM   #4
Usercpy
 
ilikeching's Avatar
 
Join Date: Aug 2012
Posts: 205
Garage
I had this problem before, but the fuse of my instrument cluster went of all the time.....so i removed the instrument cluster to check the plugs and wires, and cleaned a little bit with oxide clean and contact protect... that helped and its working fine now. that was a year ago.
heres a link how to remove the cluster and give it a try:
Instrument Cluster
__________________
http://www.flickr.com/photos/flickr_ching/
ilikeching is offline   Reply With Quote
Old 09-24-2013, 02:15 PM   #5
Registered User
 
Join Date: Sep 2013
Posts: 2
Thanks all for the advice.

Seems the barrels at fault then. I'll strip it down and give it a good clean. If that doesn't work, a new unit it is then!

Good forum this

SC'ed S2000 is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 03:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page