View Single Post
Old 10-11-2014, 10:18 AM   #3
JFP in PA
Registered User
 
Join Date: Feb 2005
Location: It's a kind of magic.....
Posts: 5,598
Quote:
Originally Posted by kuwahara86 View Post
Hi All i have a 2003 boxster S and the analog clcoks have stopped working, the digital ones work but the analog speedo,fuel gauge,temp gauge etc have stopped. this happen whilst driving and i could smell burning i pulled up and lifted the front hood and there was smoke starting to come from the passenger side (uk ) i took off the interior light cover under the hood and noticed the light fitting was totally melted with exposed copper wire touching the met bodywork it didnt catch fire fully just started to smoulder, anyway it stopped doing this and i managed to drive home about 9 miles the thing is since this the clocks have been stuck at 50mph and the fuel gauge where it was at quarter and temp at half, iv now changed the wiring loom that had melted but the clocks still didnt work so i changed the ignition switch still nothing all fuses appear ok so im stumped the car drives perfect everything else works but this can anyone maybe shed some light on this please help !!!
Check the current distributor (behind the HVAC box on the passenger's side). These are a set of heavy (60-80) amp fuses that are the last line of defense in an electrical short.



__________________
Anything really new is invented only in one’s youth. Later, one becomes more experienced, more famous – and more stupid.” - Albert Einstein
JFP in PA is online now   Reply With Quote