Go Back   986 Forum - The Community for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Performance and Technical Chat

Post Reply
 
LinkBack Thread Tools Display Modes
Old 06-24-2022, 09:47 AM   #1
Registered User
 
Join Date: Jun 2017
Location: West Hollywood, CA
Posts: 54
instrument cluster backlight issues

03 bosxter base, manual. I suddenly lost my cluster backlight, went to my trusty Bentley to see how to pull it and replace the bulbs, and once i got it removed discovered I have a different cluster than the one illustrated. there are no tabs to slide out to separate the parts; no bulb housings visible at all before disassembly. (i understand the cluster backlight are not in the strip of idiot lights, but not seeing that strip of bulbs was a red flag that something was going to be different). So now I have the cluster out but still can't get at the bulbs. Can anyone point me to another procedure doc that might cover mine, or tell me what to try. looks like thre are two white tabs to lift but that doesn't separate; there's one small torx that seems to hold but taking that out didn't do it, i must be missing something and don't want to break fragile 20 year old plastic......

bmsamson is offline   Reply With Quote
Old 06-24-2022, 10:17 AM   #2
Registered User
 
Join Date: Jun 2017
Location: West Hollywood, CA
Posts: 54
back to the drawing board

so i got it apart (sure hope I remember how to put it back together) and mine doesn't have any removable bulbs.

i read a couple of folks commenting the issue they had like mine was traced back to the headlight switch somehow. guess I'll explore that next, once i get my cluster reinstalled.
bmsamson is offline   Reply With Quote
Old 11-24-2022, 08:50 AM   #3
Registered Member
 
Join Date: Jul 2022
Location: Lafayette, IN
Posts: 7
Garage
I had the same issue with my 2004 S. After checking fuses and taking the lnstrument cluster apart and not finding replaceable bulb I learned of the headlamp switch as a possible root cause. The other symptom was no dimmer adjustment screen would pop up. I replaced the switch which resolved the problem.

muledog is offline   Reply With Quote
Post Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 08:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page