Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Performance and Technical chat

Reply
 
LinkBack Thread Tools Display Modes
Old 08-28-2016, 01:23 PM   #1
Registered User
 
Join Date: Apr 2016
Location: Tannersville PA
Posts: 471
Clock Won't Set

Well I replaced the little rods that go into the cluster for clock and ODO (mine had broken off). Now the ODO/Dimmer works fine but the clock will not set. I push in the rod and nothing happens. The clock displays and keeps time I just can't set it. Any thoughts?

Thanks
achillies is offline   Reply With Quote
Old 08-28-2016, 02:53 PM   #2
Registered User
 
kjc2050's Avatar
 
Join Date: Oct 2012
Location: Wake Forest, NC
Posts: 847
Garage
If all else fails, momentarily disconnect your battery at Noon one day. ;-)
__________________
2000 Boxster S, 6 speed, Sport Package, Litronics, LED tail lights, LNE IMS-B, OBC, Skybreaker wind deflector, Arctic Silver/Graphite Grey
kjc2050 is offline   Reply With Quote
Old 08-30-2016, 08:49 PM   #3
Registered User
 
madmodz's Avatar
 
Join Date: Jul 2012
Location: Scottsdale, AZ
Posts: 174
Quote:
Originally Posted by kjc2050 View Post
If all else fails, momentarily disconnect your battery at Noon one day. ;-)
haha, it would actually work!
madmodz is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 04:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page