Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Performance and Technical chat

Reply
 
LinkBack Thread Tools Display Modes
Old 12-21-2008, 08:08 PM   #1
Registered User
 
Join Date: Jan 2008
Location: North County, San Diego
Posts: 21
Brake Wear light????

I was at the track when my "Brake Wear" light came on and stayed on. Had the mechanic checks all brakes and wear sensors, he says they are all good. The dealer wants $300 just to look at it.

Any ideas???

Thanks
CBAD-986 is offline   Reply With Quote
Old 12-22-2008, 07:03 PM   #2
Registered User
 
Lil bastard's Avatar
 
Join Date: Feb 2008
Location: Du Monde
Posts: 2,199
How is the pedal feel? Have you blown the master cylinder?

Also, did the mechanic just do a visual test on the wear sensors? The actual wire can easily break inside the teflon sheath. I would do a continuity test on each one with a DMM. All you'd need to do is disconnect the electrical connector and test for continuity between the pins. My suspicion is that this is the problem.
__________________
1990 Porsche 964 Carrera 4 Cabriolet
1976 BMW 2002
1990 BMW 325is
1999 Porsche Boxster
(gone, but not forgotten)
http://i933.photobucket.com/albums/a...smiley-003.gif

Never drive faster than your Guardian Angel can fly!
Lil bastard is offline   Reply With Quote
Old 12-25-2008, 11:12 AM   #3
Registered User
 
Join Date: Oct 2008
Location: Milford, Ks.
Posts: 73
Quote:
Originally Posted by Lil bastard
How is the pedal feel? Have you blown the master cylinder?

Also, did the mechanic just do a visual test on the wear sensors? The actual wire can easily break inside the teflon sheath. I would do a continuity test on each one with a DMM. All you'd need to do is disconnect the electrical connector and test for continuity between the pins. My suspicion is that this is the problem.


this issue has happened on a friend of mines car and it was indeed the wire. he said it was a cheap fix though.
__________________
-Jeff-
"I'm a glutton for punishment when it comes to my boxster"
'03 S/ PSS9/ B&M short throw/ EVOMS intake/ NHP full exhaust w/ headers / Cantrell MS custom tune
boxster_s_boy_34 is offline   Reply With Quote
Old 12-26-2008, 04:10 PM   #4
Registered User
 
Join Date: Jan 2008
Location: North County, San Diego
Posts: 21
brake sensors

I talked with the mechanic and he stated they did a resistance test on each sensor and it all looked good. They checked the system up to the computer and that checked out. He believes the problem is between the computer and the dash.

He talked to a porsche mechanic in LA and was told that sometomes flashing the computer will fix it and other times they have been required to replace the instrument cluster????

Thanks for the sugestions
CBAD-986 is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 12:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page