Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 08-22-2016, 03:49 PM   #1
Registered User
 
Join Date: Aug 2016
Location: NH
Posts: 3
Instrument Cluster Woes

Hello, everyone.

My speedometer, Tachometer, and all of the lower info LCDs are not functioning. They can be manually triggered with Durametrics but do not operate with the car. The speedo and tach stay at 0 while the LCDs are backlit and blank. The temp/fuel gauges and warning lights are fine, however. Any and all info would be greatly appreciated. 1998 Boxster. Also I checked all fuses and have tried to find if a relay is the culprit, but no luck.

Thanks you!

huntern321 is offline   Reply With Quote
Old 08-22-2016, 04:17 PM   #2
Project Addicted
 
jcslocum's Avatar
 
Join Date: Aug 2015
Location: Eastern Shore, MD
Posts: 623
I had a dead-ish dash and had to replace it. Did lots of fussing to get it to work and none of it helped. I got a used one from Woody on this list.
__________________
______
Jon
1966 912, 1976 911
1986 944, 2000 Boxster
jcslocum is offline   Reply With Quote
Old 08-22-2016, 04:40 PM   #3
Registered User
 
Join Date: Aug 2016
Location: NH
Posts: 3
Quote:
Originally Posted by jcslocum View Post
I had a dead-ish dash and had to replace it. Did lots of fussing to get it to work and none of it helped. I got a used one from Woody on this list.
I just find it curious that I would have a bad instrument cluster if I can trigger all the dials through OBD II.
huntern321 is offline   Reply With Quote
Old 08-22-2016, 05:08 PM   #4
Registered User
 
KevinH1990's Avatar
 
Join Date: Feb 2006
Location: Virginia
Posts: 1,367
This may be a bit of a long shot, but I suggest that you search on the terms "ignition switch" and "cluster" to see if anyone else has had the same problem due to a bad ignition switch. A failed switch can cause some seemingly unrelated problems.

Another possible check is to make sure all of the connectors are seated properly.
__________________
2000 Arctic Silver/Black, Hard Top, On Board Computer
PNP Rear Speakers, HAES 6-channel amp, Avic Z140BH,
Painted Bumperettes, 2004 (OEM) Top and Frame
Homelink transmitter integrated in dash with Targa switch
Carrera Gauge Cluster with silver gauge faces, heated seats, litronics, painted console
KevinH1990 is offline   Reply With Quote
Old 08-23-2016, 08:43 AM   #5
Registered User
 
Join Date: Aug 2016
Location: NH
Posts: 3
This person seems to have been experiencing my exact same issue with their 996:

Need Help, Instrument Cluster Does Not Work Completly Anymore - 996 Series (Carrera, Carrera 4, Carrera 4S, Targa) - RennTech.org Community

huntern321 is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 01:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page