Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 03-18-2015, 12:39 PM   #1
Registered User
 
BIGJake111's Avatar
 
Join Date: Dec 2013
Location: Greenville, S.C.
Posts: 2,656
Garage
CEL troubles

P1128 and p1130.

The cars has had a light for a while now and we've done several things to try and fix it. First cleaning MAF and throttle body, then eventually replacing the MAF. Each time the light has been cleared. It has returned a few days later.

After the MAF the car now drives and idles perfect though, it had a surging idle before then. So the new MAF has definitely affected the car for the better. I am just stumped by the return of a CEL again.

Car is a 2000 Boxster S with 91k on the odometer. No symptoms now that idle is fixed.
(Just to add, the AOS was replaced already by PO around 14k miles ago.)


Last edited by BIGJake111; 03-18-2015 at 12:47 PM.
BIGJake111 is offline   Reply With Quote
Old 03-18-2015, 03:36 PM   #2
Registered User
 
fullthrottle52's Avatar
 
Join Date: May 2011
Location: Greensboro, NC
Posts: 238
Could be many things, but I had the same codes and battled them so quite awhile. Have your Indi do a smoke test because you may have a vacuum leak somewhere. Mine ended up being the oil filler rube had a crack in the accordion section (common issue).

Good luck.
__________________
2000 Boxster - Loved and sold
1999 911 Cabriolet - Also loved and sold.
fullthrottle52 is offline   Reply With Quote
Old 03-18-2015, 03:36 PM   #3
Need For Speed
 
KRAM36's Avatar
 
Join Date: Feb 2013
Location: Funville
Posts: 2,106
Garage
Jake do you have a Durametric?

I would start looking for some air leaks.



Not sure what you used previously to clean your MAF sensor, but CRC MAF sensor cleaner can be sprayed thoroughly all around any spot in the engine compartment to find a leak and it will not harm any components.
__________________
2003 Boxster S
| 987 Air Box | K&N Air Filter | 76mm Intake Pipe| 996 76mm TB | 997 Distribution T | Secondary Cat Delete Pipes | Borla Muffler | NHP 200 Cell Exhaust Headers |
KRAM36 is online now   Reply With Quote
Old 03-18-2015, 04:43 PM   #4
Registered User
 
Join Date: Apr 2012
Location: Saint Paul, MN
Posts: 105
Could it be something silly, like a fuel filler cap that doesn't seal properly anymore?
pharaohjb is offline   Reply With Quote
Old 03-18-2015, 08:05 PM   #5
Registered User
 
Jager's Avatar
 
Join Date: Jul 2010
Location: California
Posts: 1,815
Garage
Check your AOS.
__________________
Jäger

300K Mile Club
Jager is offline   Reply With Quote
Old 03-18-2015, 09:09 PM   #6
Registered User
 
BIGJake111's Avatar
 
Join Date: Dec 2013
Location: Greenville, S.C.
Posts: 2,656
Garage
Quote:
Originally Posted by Jager View Post
Check your AOS.

Would it be possible for it to go out again in such a short amount of time?
BIGJake111 is offline   Reply With Quote
Old 03-19-2015, 03:19 AM   #7
Registered User
 
Join Date: Feb 2005
Location: It's a kind of magic.....
Posts: 5,160
Quote:
Originally Posted by BIGJake111 View Post
Would it be possible for it to go out again in such a short amount of time?
Yes, we have seen them fail in 1000 miles.
__________________
Anything really new is invented only in one’s youth. Later, one becomes more experienced, more famous – and more stupid.” - Albert Einstein
JFP in PA is offline   Reply With Quote
Old 03-19-2015, 05:42 AM   #8
Registered User
 
Join Date: Nov 2013
Location: Emerald City
Posts: 885
Garage
I battled them for a long time too. When you installed the new maf did you pull the neg battery cable to reset fuel trims? I ended up putting in a bottle of that Techtron fuel system cleaner and driving the crap out of it. that also helped.
jdraupp is offline   Reply With Quote
Old 03-19-2015, 08:46 AM   #9
Registered User
 
kk2002s's Avatar
 
Join Date: Sep 2012
Location: S. New Jersey
Posts: 1,210
Garage
Quote:
Originally Posted by pharaohjb View Post
Could it be something silly, like a fuel filler cap that doesn't seal properly anymore?
This is usually P0442 (NJ gas attendants constantly not screwing gas cap tight enough)
1128, 1130 for me was vacuum leak - AOS to Throttle body hose not seated correctly
there are lots of hoses and connectors that could be culprit

After clearing codes, it would take 100+ miles to re display until I found and fixed

__________________
2002 S - old school third pedal
Seal Grey
kk2002s is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 10:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page