Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 04-06-2013, 11:15 AM   #1
Registered User
 
mikesz's Avatar
 
Join Date: Feb 2013
Location: Cranston RI
Posts: 858
Garage
Boxster running rough no

Had CEL. Last weekend I got under the hood and changed the air filter it was the worst I have ever seen. Got the shop vac and vacuumed the airbox before replacing Filter. took out the MAF and cleaned it but it didn't seem to be dirty. Disconnected the battery for 40 seconds to reset the CEL reconnected and Drove around for 100 miles and no CEL. Took the car to be inspected and passed. Last night I was on the highway and hit the throttle and the care was running fine then it started running rough and backfiring through the drivers side air intake. I limped to my friends house waited about 30 minutes then started it up and car ran fine but I had CEL. Got it home ok. Went out with the durametric and checked codes 1128 and 1130. I cleared the codes with the durametric software. started the car up and went for a short ride and started "popping" again and no power. Parked it in the driveway for now. Any ideas what causes this? Up until this happened car ran great. But I have only had it for a couple of months. Seems like for every one thing I fix another thing goes.

mikesz is offline   Reply With Quote
Old 04-06-2013, 02:36 PM   #2
Registered User
 
Join Date: Mar 2005
Location: utah
Posts: 96
My guess would be its probably time to replace the MAF, make sure you get the right one as there are 3 different versions.
boxster7614 is offline   Reply With Quote
Old 04-16-2013, 06:22 PM   #3
Registered User
 
mikesz's Avatar
 
Join Date: Feb 2013
Location: Cranston RI
Posts: 858
Garage
New MAF YES! Just replaced it and running as she should!

mikesz is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 12:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page