Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 04-01-2013, 12:52 PM   #1
Registered User
 
Roger Bear's Avatar
 
Join Date: Apr 2008
Location: Edinburgh
Posts: 2
Question Boxster S Dash Help

Help please. My Boxster S Dash has started acting up. The LCD's for speed & time, the fuel warning light, and the illumination have all suddenly stopped working at the same time. The rev counter, speedo dial, odometer, water temp & fuel gauge all work ok.
Anyone experienced anything similar? Or does anyone know what the likely cause is? It's a low mileage 2000 year 'S', always garaged. Any help would be welcome.
Thanks.
Roger Bear is offline   Reply With Quote
Old 04-01-2013, 02:35 PM   #2
Registered User
 
Join Date: Dec 2012
Location: Scotland
Posts: 44
I'm nearby and have a spare dash if you need to swap it out to try that as a fix.

Duffy3074 is offline   Reply With Quote
Old 04-01-2013, 03:54 PM   #3
Registered User
 
KevinH1990's Avatar
 
Join Date: Feb 2006
Location: Virginia
Posts: 1,367
Consider checking the following:

1. Fuses
2. Ignition switch

Try a combination of searches such as: Fuse and "Gauge Cluster" or "Ignition Switch" and "Gauge Cluster" to see if someone else had a similar problem.

Another possibility is that one of the three connectors on the back has come loose. That seems unlikely unless you or a previous owner recently removed the cluster to replace a bulb and didn't reinstall it securely.


Good luck
__________________
2000 Arctic Silver/Black, Hard Top, On Board Computer
PNP Rear Speakers, HAES 6-channel amp, Avic Z140BH,
Painted Bumperettes, 2004 (OEM) Top and Frame
Homelink transmitter integrated in dash with Targa switch
Carrera Gauge Cluster with silver gauge faces, heated seats, litronics, painted console
KevinH1990 is offline   Reply With Quote
Old 04-02-2013, 09:16 AM   #4
Registered User
 
Roger Bear's Avatar
 
Join Date: Apr 2008
Location: Edinburgh
Posts: 2
Update

Thanks for the replies, I've searched other posts and couple of things to test or look for which I'll do tonight.

Meantime, any other suggestions as to the cause are welcome.
Roger Bear is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 06:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page