Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 06-28-2005, 05:37 PM   #1
Registered User
 
Join Date: Jun 2005
Location: Florida
Posts: 33
Litronics Advice

Help!
Has anyone ever had a problem with their retrofit xenon headlights not functioning correctly? All my lights worked fine but recently I noticed the main headlights were not coming on, not even a flicker. I was curious if behind the headlight switch their could be a bad connection where it turns? Or is their a relay that could be blown? I checked all the fuses aleady. Is there a main wire that could've come undone where the lights are installed that is strictly for the headlights? If I call Porsche are they going to say I am screwed?!

ANY information will be very much appreciated.

RENNX is offline   Reply With Quote
Old 09-25-2006, 04:09 AM   #2
Registered User
 
Euphoria's Avatar
 
Join Date: Aug 2003
Location: Bahrain
Posts: 18
Send a message via ICQ to Euphoria
Exclamation Litronic Problem

Quote:
Originally Posted by RENNX
Help!
Has anyone ever had a problem with their retrofit xenon headlights not functioning correctly? All my lights worked fine but recently I noticed the main headlights were not coming on, not even a flicker. I was curious if behind the headlight switch their could be a bad connection where it turns? Or is their a relay that could be blown? I checked all the fuses aleady. Is there a main wire that could've come undone where the lights are installed that is strictly for the headlights? If I call Porsche are they going to say I am screwed?!

ANY information will be very much appreciated.
Hi RENNX,

I currently have the same problem. The dealership told me i need to get a new light switch. What did you do to solve the problem? did you need to change the switch?

Your feedback would be appreciated because i have my doubts about what the dealership are telling me.

Thank you,
Euphoria
Euphoria is offline   Reply With Quote
Old 09-25-2006, 02:10 PM   #3
Registered User
 
Join Date: Jul 2006
Location: mid-Michigan
Posts: 562
Quote:
Originally Posted by RENNX
Help!
Has anyone ever had a problem with their retrofit xenon headlights not functioning correctly? All my lights worked fine but recently I noticed the main headlights were not coming on, not even a flicker. I was curious if behind the headlight switch their could be a bad connection where it turns? Or is their a relay that could be blown? I checked all the fuses aleady. Is there a main wire that could've come undone where the lights are installed that is strictly for the headlights? If I call Porsche are they going to say I am screwed?!

ANY information will be very much appreciated.
__________________________________

What is the year and specific model of your car?

__________________
2000 Arctic Silver Boxster
SPQR
Senatus Populusque BoxsterRomanus
jeffsquire is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 03:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page