Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 12-08-2008, 05:41 PM   #1
Registered User
 
Join Date: Oct 2007
Location: England
Posts: 3
Litronic

I just purchased a set of Litronic headlights, I tried to plug them into my 1999 Boxster with no luck. Does anyone know what I might be doing wrong? Thanks


Last edited by krdehner; 12-08-2008 at 05:57 PM.
krdehner is offline   Reply With Quote
Old 12-08-2008, 07:59 PM   #2
Registered User
 
Join Date: Jul 2004
Location: Houston, Texas
Posts: 7,236
I plugged mine in and they worked right away. The electronic box that tilts them up when the high beams didn't work, but everything else worked fine without any mods.

Did you check the fuse?
__________________
'97 Boxster (Black Hole for 42,000 Dead Presidents and counting) - 122k
New motor, transmission, suspension, and on and on and on it goes...
RandallNeighbour is offline   Reply With Quote
Old 12-09-2008, 05:49 AM   #3
Registered User
 
Join Date: Aug 2007
Location: CA
Posts: 115
I'm not sure I understand - is there a problem getting them to install in the openings and lock in? Or do they not illuminated once installed?

Not to imply that I would have a solution either way, I just wanted to clear up the nature of the problem in case anyone else has some insight.
Ofishbein is offline   Reply With Quote
Old 12-09-2008, 10:05 AM   #4
Registered User
 
Join Date: Mar 2007
Location: Marin, CA
Posts: 36
Litronics

krdehner-

I also have a '99 boxster and I installed Litronics (which I purchased new from Suncoast). It should be a straight swap. All the HID wiring and ballasts are located within your litronic headlight units. You should be able to slide the old lights out, and slide the new lights in. This is what I did and mine work perfectly. As randall mentioned, my HID light beams do not tilt up when I turn on my brights because I did not install the electric box which causes them to do so.

Did your purchase your headlights new or used?
achillian is offline   Reply With Quote
Old 12-13-2008, 05:17 AM   #5
Registered User
 
Join Date: Oct 2007
Location: England
Posts: 3
Quote:
Originally Posted by RandallNeighbour
I plugged mine in and they worked right away. The electronic box that tilts them up when the high beams didn't work, but everything else worked fine without any mods.

Did you check the fuse?
They are missing one bulb, but none of the lights work. I put my standard ones in and they work, so I don't think it could be the fuse.
krdehner is offline   Reply With Quote
Old 12-13-2008, 05:26 AM   #6
Registered User
 
Join Date: Oct 2007
Location: England
Posts: 3
Quote:
Originally Posted by achillian
krdehner-

I also have a '99 boxster and I installed Litronics (which I purchased new from Suncoast). It should be a straight swap. All the HID wiring and ballasts are located within your litronic headlight units. You should be able to slide the old lights out, and slide the new lights in. This is what I did and mine work perfectly. As randall mentioned, my HID light beams do not tilt up when I turn on my brights because I did not install the electric box which causes them to do so.

Did your purchase your headlights new or used?
I got them from a guy who pulled them from his Boxster, so I guess if I can't them to work I am going to have to return them.
krdehner is offline   Reply With Quote
Old 12-13-2008, 11:39 AM   #7
Registered User
 
Join Date: Sep 2006
Location: chicago
Posts: 3,510
Send a message via AIM to djomlas
should be plug and play
im on my 3rd set so far, and they all have been plug and play
__________________
http://i34.tinypic.com/157yslk.jpg
"I couldn't find the sports car of my dreams, so I built it myself." ~F. Porsche
Gemballa springs::litronics::Eurotech 18s(275/225)::B&M::MOMO wheel::
exhaust cutouts::EVOcoldair intake::OEM smoked tails & sidemarkers::

colormatched bumperettes::Top Speed Pro-1 exhaust::
my cardomain/pictures page
djomlas is offline   Reply With Quote
Old 12-13-2008, 02:12 PM   #8
Registered User
 
Join Date: Dec 2006
Location: Chicago
Posts: 291
Quote:
Originally Posted by djomlas
should be plug and play
im on my 3rd set so far, and they all have been plug and play

Third set? Where are you getting them from?

shaman1204 is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 10:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page