Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 09-25-2019, 05:00 PM   #1
Registered User
 
gabedrummin's Avatar
 
Join Date: Jan 2018
Location: Houston
Posts: 126
Garage
Durametric

My durametric wont talk to the air bag module. I have an airbag light .My air bags are all good have not blown one .I have a problem with the clock spring not returning turn signal to neural position .Read some where that there is two plastic tabs on clock spring cover when the plastic breaks it wont return turn signal lever My question is dose the air bag signal go through the clock spring? Thanks guys.

gabedrummin is offline   Reply With Quote
Old 09-25-2019, 06:55 PM   #2
Custom User Title Here
 
particlewave's Avatar
 
Join Date: Mar 2012
Location: WA
Posts: 6,084
Garage
What year is your car?

Yes, the airbag wires go through the clockspring, but that has nothing to do with the Durametric not communicating with the module.
particlewave is offline   Reply With Quote
Old 09-26-2019, 05:01 AM   #3
Registered User
 
gabedrummin's Avatar
 
Join Date: Jan 2018
Location: Houston
Posts: 126
Garage
She's a 2000 3.2 boxsterS
gabedrummin is offline   Reply With Quote
Old 09-26-2019, 06:05 AM   #4
Registered User
 
Join Date: Mar 2018
Location: Fort Langley
Posts: 100
My Durametric has issues connecting with certain modules as well. Airbag being one of them. alarm module and dash as well. I believe it has to do with some water damage to my CLU. Something I intend to get fixed but it's not been a priority as it still runs and drives great. My Boxster is a 1998.
__________________
----------------------------
98 Boxster - bringing it back to life and having fun doing it!
20 Harley Streetbob -
Zzorro is online now   Reply With Quote
Old 09-26-2019, 12:58 PM   #5
Registered User
 
gabedrummin's Avatar
 
Join Date: Jan 2018
Location: Houston
Posts: 126
Garage
I drowned my ecu, it had to be replaced .All was good ,and one day I go to adjust the steering wheel .Where you can push it down or pull it towards you . That's when I notice the air bag light went off . Now I know the clock spring has been kind of goofey for awhile .I the morning you get no light for the cruise control but in the after noon it works has been like this since the day I got her. So I figure it is all tied together guess I'm wrong.
gabedrummin is offline   Reply With Quote
Old 09-26-2019, 02:19 PM   #6
Registered User
 
Join Date: May 2019
Location: East Coast
Posts: 22
Garage
I had to just replace my Immobilizer/Key/Lock and matching computer because of a soaked Immobilizer. I would take it out and rinse it down with alcohol and a small brush. Clean the connectors with electronics cleaner... Make sure everything is dried and put it back together. Mine was horrible and that worked for a while. There are videos all over for doing this. Worse case scenario, I spent $400 for a whole new set of everything(except door locks-I just use the remote. Good Luck
OH and when you put it back put it in a Tupperware container with some silicon to seal the wires - worked for me!
DMags is offline   Reply With Quote
Old 09-26-2019, 02:35 PM   #7
Custom User Title Here
 
particlewave's Avatar
 
Join Date: Mar 2012
Location: WA
Posts: 6,084
Garage
Quote:
Originally Posted by gabedrummin View Post
She's a 2000 3.2 boxsterS
I asked because the v2 cables have issues sometimes connecting with earlier car modules.

However, this doesn’t seem to apply to you. I would start by replacing the clockspring since you know it has an issue.
There is also a connector in the column that has been known to disconnect and trip the light.

As far as the Durametric, neither above issues would prevent it from communicating, so you may have a module issue. I’d start by fixing the known problems and go from there.
particlewave is offline   Reply With Quote
Old 10-06-2019, 09:09 AM   #8
Registered User
 
gabedrummin's Avatar
 
Join Date: Jan 2018
Location: Houston
Posts: 126
Garage
New clock spring fixed both issues air bag light is off and turn signal working ,

gabedrummin is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 02:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page