Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 09-30-2014, 04:09 PM   #1
Registered User
 
fullthrottle52's Avatar
 
Join Date: May 2011
Location: Greensboro, NC
Posts: 238
Radio / CD issue

I have done a search and have not had any luck with an answer. I am hoping someone has had this problem before.
Here goes: just bought a 1999 911. Same radio as the boxster (base Becker 220).
Radio works fine - no issues. When I put a cd in the slot it plays just fine. Volume works but if you try to change to another track (turning the right nob or pushing it in) it freezes up all controls and the CD player keeps playing. You can't control anything at that point and it just keeps playing at the volume you set, even if the car is turned off. The only way to get it to quit playing is to restart the car and then the volume works again. You can then reject the cd and your back in business. Happens every time you hit the right nob with a cd in. Real pain in the ........

Any ideas from the best forum anywhere.

May just need to replace the radio.

__________________
2000 Boxster - Loved and sold
1999 911 Cabriolet - Also loved and sold.
fullthrottle52 is offline   Reply With Quote
Old 10-01-2014, 12:39 PM   #2
Registered User
 
Join Date: Jan 2007
Location: BC
Posts: 1,281
Try cleaning the contacts with alcohol between the faceplate and the main unit. Dirty contacts can create some strange behaviour.
__________________
2001 Boxster, 5 spd, Seal Grey
clickman is offline   Reply With Quote
Old 10-01-2014, 01:43 PM   #3
Registered User
 
fullthrottle52's Avatar
 
Join Date: May 2011
Location: Greensboro, NC
Posts: 238
Quote:
Originally Posted by clickman View Post
Try cleaning the contacts with alcohol between the faceplate and the main unit. Dirty contacts can create some strange behaviour.
Thanks Clickman, I'll give it a try.
__________________
2000 Boxster - Loved and sold
1999 911 Cabriolet - Also loved and sold.
fullthrottle52 is offline   Reply With Quote
Old 10-04-2014, 03:03 PM   #4
Registered User
 
fullthrottle52's Avatar
 
Join Date: May 2011
Location: Greensboro, NC
Posts: 238
Tried clleaning the contacts with no change in behavior. Same issue. Anyone have any other ideas before I just scrap it. P.S. - I discovered today that if you put a CD in and play it, it goes to whatever track it feels like. Went from #1 to 17 to 16 and back to one. I guess it may be time to connect an I pod adaptor or replace it.
__________________
2000 Boxster - Loved and sold
1999 911 Cabriolet - Also loved and sold.
fullthrottle52 is offline   Reply With Quote
Old 10-04-2014, 03:08 PM   #5
still plays with cars...
 
BoxsterSteve's Avatar
 
Join Date: May 2011
Location: Baden, ON, Canada
Posts: 1,084
Garage
+1 on an IwireP cable. Took all of 10 minutes to install.

__________________
Six speed 2000 Boxster S
Arctic Silver on Metropol Blue | LN Dual Row IMSR | Arctic Silver console, spoiler frame & bumperettes | Crios mod | Technobrace | RoboTop module & modified convertible top relay for one-touch roof operation
BoxsterSteve is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 04:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page