Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 03-07-2006, 01:29 PM   #1
Registered User
 
slogans7's Avatar
 
Join Date: May 2005
Location: San Clemente, CA
Posts: 244
What's up with my temp LCD?

I've got a weird mar or partial failure in this LCD. It's not terrible, but just a little annoying. There are a couple of spots that always are illuminated. Anyone know how to fix?

__________________
2002 Triple-Black Boxster S
slogans7 is offline   Reply With Quote
Old 03-07-2006, 01:32 PM   #2
Registered User
 
Join Date: Jul 2004
Location: Houston, Texas
Posts: 7,241
I do not believe individual LED segments can be fixed. They sure aren't fixable on the instrument clusters.

You're looking at the need for a whole new unit, or at least a used one in working condition. Used ones on Ebay go for about $400 plus installation, of course.

I recommend just living with it if you can. At least it's not your digital speedo readout like I had. That I could NOT live with for any time at all.
__________________
'97 Boxster (Black Hole for 42,000 Dead Presidents and counting) - 122k
New motor, transmission, suspension, and on and on and on it goes...
RandallNeighbour is offline   Reply With Quote
Old 03-07-2006, 01:34 PM   #3
Registered User
 
slogans7's Avatar
 
Join Date: May 2005
Location: San Clemente, CA
Posts: 244
Thanks Randall. $400, huh? I think I'll suffer with it. Or stick my head out the window if I'm that curious about the temp.
__________________
2002 Triple-Black Boxster S
slogans7 is offline   Reply With Quote
Old 05-05-2006, 11:36 AM   #4
Registered User
 
slogans7's Avatar
 
Join Date: May 2005
Location: San Clemente, CA
Posts: 244
It cleared up

I just noticed the little imperfections went away on their own. Happy day!
__________________
2002 Triple-Black Boxster S
slogans7 is offline   Reply With Quote
Old 05-05-2006, 12:17 PM   #5
Registered User
 
Join Date: Sep 2005
Location: Minneapolis/St. Paul, Minnesota, USA
Posts: 3,308
Hi,

Tha marks in your 1st pictures are indicative of the Display being pressed in with some force. Perhaps when cleaning it? Sometimes these will clear themselves while other times they can be permanent. My suggestion is to clean this display, and any LCD for that matter, rather gingerly. Hope this helps...

Happy Motoring!... Jim'99
MNBoxster is offline   Reply With Quote
Old 05-05-2006, 02:15 PM   #6
Registered User
 
Join Date: Nov 2005
Location: Idianapolis, IN USA
Posts: 52
Don't want to hijack this thread but I noticed that the LCD display in my BOX displays the OFF message as OFf with the last "F" being a capital but a smaller type point....looks goofy but obviously doesn'r affect the operation....anybody ever seen something like this?
__________________
Paul
2004 Boxster
Triple black
stock as a rock
ford40 is offline   Reply With Quote
Old 05-05-2006, 03:54 PM   #7
Registered User
 
Join Date: Apr 2006
Location: Arizona
Posts: 141
I think they all do that as the first two LCD digits are for the temp, and the third one (the lowercase f) was probably sqeezed in there just so they could say the whole word "OFf" Don't worry, mine does that too.

Wintermute is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 08:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page