Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 02-17-2006, 03:36 PM   #1
Registered User
 
Join Date: Oct 2005
Location: Socal
Posts: 4
Whats wrong with my speedo?

I took my car out of the garage today and I noticed that although the lights on the cluster work it stays at zero no matter how fast I go. Has anyone had any experience with this? Please help.

villwil is offline   Reply With Quote
Old 02-17-2006, 04:10 PM   #2
Registered User
 
Join Date: Sep 2005
Location: Minneapolis/St. Paul, Minnesota, USA
Posts: 3,308
Quote:
Originally Posted by villwil
I took my car out of the garage today and I noticed that although the lights on the cluster work it stays at zero no matter how fast I go. Has anyone had any experience with this? Please help.
Hi,

WHAT MODEL AND MODEL YEAR DO YOU HAVE???? MANUAL OR TIPTRONIC S??? NO CLAIRVOYANT HERE!!

Also, which Speedo, the Analog one or the Digital one? If the Analog, it could need repair, if the Digital, it could be the DME or Speed Sensor or a Fuse - check Fuse B1 (15 Amp).

The first thing to do is try disconnecting the Battery and leaving it for 5-10 min. then reconnect and see if this doesn't sort it out.

If not, you could check the Speed Sensors mounted at each Wheel to insure that their connectors are tight. Other than this, I'm afraid a Service Call will be needed. Hope this helps...

Happy Motoring!... Jim'99
MNBoxster is offline   Reply With Quote
Old 02-18-2006, 09:22 PM   #3
Registered User
 
Rail26's Avatar
 
Join Date: Jun 2005
Location: El Paso
Posts: 1,147
He he...he said "What's wrong with his speedo?" Oh the many possibilities of the perfect reply's!
__________________
'05 987 Basalt Black/Sand Beige
5 spd, 18" wheels
AH-64 Apache
RC-12 Guardrail
RC-7 Crazy Hawk

"If the wings are traveling faster than
the fuselage, it's probably a helicopter--
and therefore, unsafe" --Unknown
Rail26 is offline   Reply With Quote
Old 02-19-2006, 04:58 AM   #4
fab
Registered User
 
fab's Avatar
 
Join Date: Feb 2005
Location: Boston MA
Posts: 386
Rail26,

LOL...

Fab
00 Boxster Blk/Blk tip
fab is offline   Reply With Quote
Old 02-22-2006, 11:20 PM   #5
Registered User
 
Join Date: Oct 2005
Location: Socal
Posts: 4
sorry about the confusion, its a 97 and its the digital speedometer that stays at zero.

villwil is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 06:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page