Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 07-05-2011, 04:43 PM   #1
2001 RUF 3800S
 
violametallic-S-'s Avatar
 
Join Date: Mar 2009
Location: Ontario, Canada
Posts: 326
HELP.. Xenon light switch broke, lights don't work. Getting dark..

My switch for my head lights has been acting
Up lately. Every time I try and turn on the lights they will flicker. So I would have to turn it on and off until they come on. And today it's seems done completely, I'll turn it to the on switch and it will make a sound and nothing..... What to do? I'm gonna be driving in the night soon....

__________________
IG: RUF3800S
violametallic-S- is offline   Reply With Quote
Old 07-05-2011, 07:04 PM   #2
Registered User
 
Join Date: Apr 2006
Location: Tejas/NorCal
Posts: 201
More than likely it is the ignition switch...try wiggling the key/turning it just slightly backward. Had the SAME thing happen when I installed my xenons, turned out it was the ignition switch.
tightbox is offline   Reply With Quote
Old 07-06-2011, 06:25 AM   #3
Registered User
 
ppbon's Avatar
 
Join Date: Nov 2005
Location: Florida
Posts: 529
It's either the light's switch or the ignition switch.
I'd venture a guess that it's the former.
Here are the DIY instructions to replace them both:

http://www.pedrosgarage.com/Site_3/Replace_Lights_Switch.html
http://www.pedrosgarage.com/Site_3/Replace_Ignition_Switch.html

Happy Boxstering,
Pedro
__________________
Racecar spelled backwards is: Racecar!
ppbon is offline   Reply With Quote
Old 07-07-2011, 12:59 PM   #4
2001 RUF 3800S
 
violametallic-S-'s Avatar
 
Join Date: Mar 2009
Location: Ontario, Canada
Posts: 326
Thanks!

I'm leaning towards the light switch. It's on order.

I'll report back.
__________________
IG: RUF3800S
violametallic-S- is offline   Reply With Quote
Old 07-10-2011, 07:31 AM   #5
Registered User
 
Join Date: Jun 2006
Location: Canada
Posts: 33
I got the same problem as you, it was the light switch, i remove it and clean it with contact cleaner and that resolve the problem.

Pierre is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 10:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page