Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 07-27-2010, 08:50 AM   #1
Opposed to Subie Burble
 
Overdrive's Avatar
 
Join Date: Mar 2007
Location: Central CT
Posts: 1,197
Garage
delay wiper relay, strange noise

Hey, everyone. Another small question from yours truly regarding my '97 986, trying to see if there's an issue or not with my wiper relay. When I set the wipers to the intermittent (delay) setting, the first movement is noise free. Any time after that, though, the relay makes this odd noise when it cycles...it almost sounds like the relay clicks several times very rapidly rather than just the one click you'd expect when it breaks contact. The movement is completely fine, though. It still does a nice smooth wipe, and the noise only happens at this setting...no strange noises at the low and high speed settings. I don't recall my sister's '99 making such a noise at that setting (then again, I don't recall getting caught in the rain in it, either ), but I just wanted to know if anyone else has experienced this, if it means the relay needs replacement, or if it's just the normal thing? Thanks for your time.

__________________
-O/D

1997 Arctic Silver Boxster, 5-spd
IMSR + RMS
Robbins glass window top
Overdrive is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 03:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page