Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Performance and Technical chat

Reply
 
LinkBack Thread Tools Display Modes
Old 08-20-2013, 10:31 AM   #1
Registered User
 
Join Date: Aug 2013
Location: Houston tx
Posts: 5
Upgraded to stage ! clutch and alluminum flywheel....CAR WONT START!!!! Please help!!

I recently did a clutch upgrade on my 97 Boxster.... went with clutch masters stage one kit and aluminum flywheel from Andy's auto sport. did the job as well as the IMS bearing replacement from pelican parts, and rear main seal. everything seemed to go smooth. put it all back together, and now the car just turns over but doesn't fire. sounds like it is trying to start but just sputters and dies.

Please help!! has anyone had this same problem?
Joelheston is offline   Reply With Quote
Old 08-20-2013, 11:03 AM   #2
Registered User
 
Join Date: Dec 2009
Location: Orange County, CA
Posts: 1,220
hmm.. you may have disconnected the crank positioning sensor?

.
Gilles is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 02:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page