Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 07-28-2006, 08:20 AM   #1
Registered User
 
Join Date: Oct 2005
Location: Las Vegas
Posts: 8
Unhappy oil warning light

Having some problems with my 2000 Boxster and the mechanics do not know what is wrong.
Oil Warning Light was coming on once in awhile, but when you accelerated or raised the RPM's the light would go off. So figured it was just low on oil, added 1 Quart and then I checked the level and it looked full. But the light returned and now the Engine Warning Light is coming on once in awhile. Took it to mechanic and they heard a whining noise when we started the car up. They said serpentine belt had to be replaced. Took engine apart and belt was fine, and with belt off, it still makes whining noise. They are now talking about oil pressure and oil pressure canister, but they said they will have to tear engine apart to try to find out what is wrong.
Note: When they hooked the car up to the machine to read the CEL, it said it was the Oxygen Sensor.
Does anybody have some thoughts on this or what might be wrong?


Last edited by 2kBoxster; 07-28-2006 at 10:09 AM.
2kBoxster is offline   Reply With Quote
Old 07-28-2006, 10:02 AM   #2
Registered User
 
Brucelee's Avatar
 
Join Date: Jun 2004
Location: Des Moines, IA
Posts: 8,083
My guess is simply a bad oil pump.

Second would be some issue between engine and semi dry sump.
__________________
Rich Belloff

Brucelee is offline   Reply With Quote
Old 07-28-2006, 12:28 PM   #3
Registered User
 
Join Date: Jul 2006
Location: Where the Sewer Meets the Sea, CA. USA
Posts: 2,695
Send a message via MSN to CJ_Boxster
Same here, oil pump goes and you will hear whining in the engine...do you hear lifter klattering yet?
__________________
--Proud Boxster Owner/Tech,

Carlos J Cazares

FastForward Performance
http://i10.photobucket.com/albums/a1...er/newsig1.jpg
CJ_Boxster is offline   Reply With Quote
Old 07-28-2006, 12:44 PM   #4
Registered User
 
deliriousga's Avatar
 
Join Date: Jun 2005
Location: USA!!
Posts: 1,159
Oil pump or oil separator. When the separator goes, the oil filler tube collapses, cracks and starts to make whining sound that is similar to a slipping belt.
__________________
1987 928S4 Silver Metallic (980)/Navy (TP) 5-Speed
2000 Boxster Speed Yellow/Black 5-Speed
1966 Wife White/Brown Top
1986 Daughter White/Brown Top (Sold!)
1992 Daughter White/Blonde Top
deliriousga is offline   Reply With Quote
Old 07-29-2006, 08:23 AM   #5
Registered User
 
Join Date: Aug 2004
Location: Canada
Posts: 188
Remove the oil pressure sender and install a gauge to measure the pressure at idle with the engine at operating temp and over the RPM range of the engine. It could be just that the pressure sender is going south.

wvicary is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 03:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page