Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 04-25-2016, 07:13 AM   #1
Registered User
 
Join Date: May 2014
Location: New Mexico
Posts: 74
Delay on opening / closing top?

Over the past year or so my 98 Boxster has developed an interesting quirk. If I turn the ignition on (engine running or not) to put the top up or down, I have to hold the switch for 30 seconds to 2 minutes before the top starts moving.

This happens going up or down. Once it starts, the switch works normally. It has nothing to do with setting the brake, or opening the upper latch (if the top is initially closed).

I think, but I'm not sure, that if I was to start the car (or maybe just ignition on) and wait for like 5 minutes, the top would work immediately.

Has anyone seen anything like this?

DG Boxster is offline   Reply With Quote
Old 04-25-2016, 07:23 AM   #2
There Is No Substitute.
 
rick3000's Avatar
 
Join Date: May 2007
Location: West Coast
Posts: 3,129
Garage
Do the windows drop immediately when you unlatch the top?
When you say the switch takes 30+ seconds, is that with you holding it down or pushing it multiple times?

My first thought would be the battery or dash switch. It does not sound like a microswitch or mechanical issue. You can get the battery tested for free at most auto parts stores.
__________________
1999 Ocean Blue Metallic Boxster - blueboxster.com
rick3000 is offline   Reply With Quote
Old 04-25-2016, 09:25 AM   #3
Registered User
 
Join Date: May 2014
Location: New Mexico
Posts: 74
The side windows drop immediately when I open the top latch. That's why I don't think it is the microswitch up at the latch.

Pushing the dash switch multiple times, or pushing harder, makes no difference. If I hold the dash switch continuously, the top will eventually start moving. Once it starts I can let go of the dash switch(motor stops) and press again (motor starts) and it all works fine. That's why I don't think it is the dash switch.

I think if I start the car, wait 5 minutes, then pop the latch and press the dash switch, it will probably work fine. I need to test more.

It feels like the body computer (or whatever controls the top) is rebooting or something after I turn the car on.

The battery is an interesting idea - I haven't had it tested. Starts the car fine. This problem will happen even with the engine running (and alternator presumably charging).

Last edited by DG Boxster; 04-25-2016 at 09:36 AM. Reason: added battery info
DG Boxster is offline   Reply With Quote
Old 04-30-2016, 09:32 AM   #4
Registered User
 
Join Date: May 2014
Location: New Mexico
Posts: 74
Update - so far if I use the car 5 minutes before trying the top I get immediate response.

This is a difficult problem to fix
DG Boxster is offline   Reply With Quote
Old 05-01-2016, 02:56 AM   #5
Registered User
 
CrisZenithBlue's Avatar
 
Join Date: Mar 2015
Location: Miami, FL
Posts: 474
A faulty ignition switch is known for many weird electrical gremlins, maybe it would affect top operation.

Another idea is the top relay. If you can find someone nearby that has the same relay model (I think they are different starting with year 2000 and up) you can do a quick swap and see if it works. Alternatively you can just buy an used relay for very cheap from Woody on here. I bought one from him and it fixed a problem I had.
CrisZenithBlue is offline   Reply With Quote
Old 05-01-2016, 02:59 AM   #6
Registered User
 
CrisZenithBlue's Avatar
 
Join Date: Mar 2015
Location: Miami, FL
Posts: 474
I would also try just pulling the top relay from unde the drivers side dash, just above the fuse box and tapping it a bit then putting it back in it takes 30 seconds. It's the big rectangular one, do a search to see how it looks like. Check for corrosion on the pins.
CrisZenithBlue is offline   Reply With Quote
Old 05-20-2016, 09:59 PM   #7
Registered User
 
Join Date: May 2014
Location: New Mexico
Posts: 74
Just to close this out - the problem was the top relay. It isn't jus a relay, it has electronics in it. I got a "new to me" one (Thanks Woody!!!) and now my top works correctly.

On to a glass window!

DG Boxster is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 02:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page