Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 02-21-2015, 07:24 AM   #1
Registered User
 
Join Date: Aug 2014
Location: Oklahoma
Posts: 156
Garage
Digital Speedo/ODO not working

Just replaced my gauge faces with some yellow ones. Plugged everything back in, now the digital speedo does not work, along with the ODO. Reset the computer with an OBD2, still the same problem. Thanks in advance

OklahomaBoxster is offline   Reply With Quote
Old 02-21-2015, 07:53 AM   #2
Registered User
 
Chuck W.'s Avatar
 
Join Date: Sep 2008
Location: Agoura Hills (LA) So.Cal.
Posts: 1,571
Unplug and replug in the three connectors. What you are describing happens when a plug is not seated properly. Same thing happened to me and others.
__________________
1995 Porsche C4 Cab

2016 BMW M2, 6 Speed LBB - ED 7/2016
1997 993 Cab - Sold; 1997 993 Turbo - Sold
2001 Boxster S - Original Owner - 30K Miles -SOLD
Chuck W. is offline   Reply With Quote
Old 02-21-2015, 07:59 AM   #3
Registered User
 
Join Date: Aug 2014
Location: Oklahoma
Posts: 156
Garage
Quote:
Originally Posted by Chuck W. View Post
Unplug and replug in the three connectors. What you are describing happens when a plug is not seated properly. Same thing happened to me and others.
Thanks! Going to try that now
OklahomaBoxster is offline   Reply With Quote
Old 02-21-2015, 09:46 AM   #4
Registered User
 
Join Date: Aug 2014
Location: Oklahoma
Posts: 156
Garage
Quote:
Originally Posted by OklahomaBoxster View Post
Thanks! Going to try that now
It works! Turns out that the plug for the ODO was not seated correctly. After 3 times of trying the speedo, it still didn't work, so we checked the bulb. Turns out that the filament was damaged. Probably happened when I took the cluster apart. Replaced the bulb, and everything is working great again! Thanks again
OklahomaBoxster is offline   Reply With Quote
Old 02-21-2015, 07:53 PM   #5
Registered User
 
Chuck W.'s Avatar
 
Join Date: Sep 2008
Location: Agoura Hills (LA) So.Cal.
Posts: 1,571
Quote:
Originally Posted by OklahomaBoxster View Post
It works!
Cool.

__________________
1995 Porsche C4 Cab

2016 BMW M2, 6 Speed LBB - ED 7/2016
1997 993 Cab - Sold; 1997 993 Turbo - Sold
2001 Boxster S - Original Owner - 30K Miles -SOLD
Chuck W. is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 10:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page