Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 10-05-2014, 09:59 AM   #1
Registered User
 
Join Date: Oct 2014
Posts: 7
Weird electrical problem?

So I have just about fixed all of the numerous problems that this car has had thank you all for your help. I have just one last predicament left my gas gauge and fuel gauge are both not working they read empty and zero? Also the the power seems to flicker when the car will come to a stop? Any ideas? All help is appreciated!
Waynecharper is offline   Reply With Quote
Old 10-05-2014, 10:35 AM   #2
Registered User
 
Pdwight's Avatar
 
Join Date: May 2013
Location: North Alabama
Posts: 2,075
Check every wire on the back of the instrument cluster and make sure non of the pins were pushed out of the connectors.
Pdwight is offline   Reply With Quote
Old 10-05-2014, 02:45 PM   #3
Registered User
 
Join Date: Oct 2014
Posts: 7
Where is the cluster located please show pictures?
Waynecharper is offline   Reply With Quote
Old 10-05-2014, 06:33 PM   #4
Registered User
 
Pdwight's Avatar
 
Join Date: May 2013
Location: North Alabama
Posts: 2,075
THe Speedometer, tachometer....right behind the steering wheel
Pdwight is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 01:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page