Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 05-14-2012, 10:37 AM   #1
Registered User
 
Join Date: Apr 2012
Location: Chicago
Posts: 1
Garage
Question Electrical issue help?

I just purchased a 1999 Boxster with 68k miles (well three weeks ago) and I am having electrical issues with it that I cannot seem to discover and rectify.

I was driving down the highway, when my battery light, check engine, ABS, and Airbag lights came on. I pulled off the road, and went to AutoZone. They told me that the battery was fine, and the alternator was bad.

I ordered a new alternator from Discount Starter and Alternator. I couldn't get the alternator bushing to move, so I had the Porsche Dealership (Rizza Porsche) install it for me.

Alternator Porsche 911 Boxster 1999-2004 996-603-012-00

The instrument cluster lights continued to dim and flicker (and it doesn't seem related to the RPM's of the engine). To the point that the engine doesn't have enough spark to continue to run. I then took it back to the Porsche dealership and paid them to diagnose the issue.

They told me it was the battery, and to replace the battery. (and that the starter is going bad). So I replaced the battery that day.

The problem did not go away. It seems to have slowly run the battery down, and the problem manifested itself yet again.

I have a new starter on order, as the only way to start the car at this point is to push start it. I think that I'll probably blow the clutch out by doing this.

Porsche Boxster Starter at Auto Parts Warehouse

The lights on the dashboard continue to flicker, but will occasionally light up quite brightly (as they are supposed to do all of the time).

At this point, I will have replaced the alternator, battery, and starter. Is there a charge regulator? I am going to check and see if there is a grounding issue (I found that on Pelicanparts.com, but haven't checked it).

Is there something else that could be causing the issue? A charge controller that is external to the alternator?

Corpusant is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 05:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page