Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 05-31-2010, 04:28 PM   #1
Registered User
 
Join Date: Mar 2009
Location: DFW, TX
Posts: 206
Garage
Windshield Wiper warning light on dash

Well first of all, I have not posted or added to a post in like....forever. Been busy, with a blown out knee (MCL, ACL and Fracture), near death experience from a Pulmonary Embolism (resulting from the blood clots from the fracture...was not fun with 6 days in ICU). AND started writing a novel that has a lot to do with cars...you guys will love it!

Anyway, I digress... the warning light on my dash that indicates some sort of problem with the windshield wiper function is glowing yellow all the time (thank God it is not a red light...). Still squarts water at the windshield when I pull back on the lever. So...what gives? How do I turn it off or any ideas what the problem could be?
__________________
rob76turbo
Current Porsches: 2002 Boxster S (Speed yellow)
Past Porsches: 1972 914, 1987 944S, 1976 930, 1986 951, 1999 986, 1992 968, 2001 986 S, 2006 Cayman S, 1986 951 track car, 2001 986 S, 2005 Cayenne
rob76turbo is offline   Reply With Quote
Old 05-31-2010, 06:44 PM   #2
Registered User
 
Join Date: Nov 2009
Location: Winnipeg MB
Posts: 2,486
The light comes on when you are down to 1/2 a litre of washer fluid left. You turn it off by adding more fluid.

That was on page 178 of your owner's manual, by the way.
__________________
'99 black 986
Mark_T is offline   Reply With Quote
Old 05-31-2010, 06:53 PM   #3
Registered User
 
Join Date: Mar 2009
Location: DFW, TX
Posts: 206
Garage
filled it to the top

To the point where it actually overflowed. So being low is not the problem. Sorry forgot to mention that in original post.
__________________
rob76turbo
Current Porsches: 2002 Boxster S (Speed yellow)
Past Porsches: 1972 914, 1987 944S, 1976 930, 1986 951, 1999 986, 1992 968, 2001 986 S, 2006 Cayman S, 1986 951 track car, 2001 986 S, 2005 Cayenne
rob76turbo is offline   Reply With Quote
Old 05-31-2010, 07:13 PM   #4
Registered User
 
Join Date: Nov 2009
Location: Winnipeg MB
Posts: 2,486
That being the case, I think I would start by checking the connection to the level indicator in the tank, and if that's good I'd probably change the sensor next.

It looks like it might be a bit of a ******************** to get at.
__________________
'99 black 986
Mark_T is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 12:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page