Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 01-29-2010, 02:28 AM   #1
Registered User
 
Join Date: Aug 2009
Location: London, UK
Posts: 155
LED central brake light - problems?

Hi - Has anyone else had issues with the central LED brake light? I've bought two smoked ones now and both have been inoperative! One supplier tried all their remaining stock and none of them worked!
I even had someone contact me through ebay because they'd had 4 in a row not work!! Apparently they're wired incorrectly.

Just wondering if anyone has had any issues over here (in the U.S) , and can reccomend somewhere to order one from?

Cheers

Gary H is offline   Reply With Quote
Old 01-29-2010, 07:16 AM   #2
07 Carrera S Cab
 
Boxtaboy's Avatar
 
Join Date: Nov 2005
Location: New Jersey
Posts: 2,273
Garage
I haven't done this mod, but I've read that you need to reverse the polarity on the wires in some cases, in order for it to work. Have you tried that?

This is what I've seen on the subject:

"Since LEDs are polarity specific and standard factory bulbs are not polarity specific, in some instances the factory wires will need to be switched around so that the positive (+) and negative (-) wires are properly matched to the LED brake light. No cutting is required, just a simple wire swap at the factory wire harness."
__________________
Current: 07 Carrera S Cab in Midnight Blue

Previous: 01 Boxster in Arctic Silver, 86 944 in Guards Red
Boxtaboy is offline   Reply With Quote
Old 01-29-2010, 08:48 AM   #3
Registered User
 
Join Date: Jun 2007
Location: Colchester, CT
Posts: 489
Correct you have to reverse the polarity by swapping the pins. Because it was random as to how the wires were installed at the factory you have a 50/50 shot. Once done the light will work and you can always put the old light back without having to undo the wires. I know this because I did it on mine but ended up putting the stock one back in.
Chris
__________________
1999 986 2.5L, Stock Exhaust (S muffler), EVO Intake, 18" Stock rims (17" during winter), IMS Upgrade, 150k+ miles and counting!
87 944S brought back to life
Dragonwind is offline   Reply With Quote
Old 01-29-2010, 10:20 AM   #4
Registered User
 
Join Date: Aug 2009
Location: London, UK
Posts: 155
Cool - thanks guys.

Gary H is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 03:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page