Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 04-25-2008, 06:42 AM   #1
Registered User
 
Join Date: Mar 2008
Location: Concord, NC
Posts: 30
Air bag light ON, Horn doesn't work.

Ok so I went to use my horn the other day, and it didn't work. I was a little shocked, but shurgged it off as I figured it was probably just a fuse that needed to be replaced. A little while down the road my air bag light came on (and is still on). That part is a little worrying, as I don't want the airbag to eject as I'm going 70mph down the interstate. I replaced the fuse for the horn but that didn't solve anything either. Any ideas, suggestions?
__________________
1997 Boxster, 60K miles
ChrisH027 is offline   Reply With Quote
Old 04-25-2008, 02:08 PM   #2
Registered User
 
Join Date: Sep 2005
Location: MARLTON, NJ
Posts: 539
Sounds like a bad clockspring...

You may need to have the dealer scan it. You are more likely not to have the
airbag deploy than suddenly deploy. When the system lamp is on it normally wont
fire the airbag in event of a collision.

Best of luck!
__________________
Joe DiMonte
2001 Boxster S
Triple Black
AUDIOGUY is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 06:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page