Go Back   986 Forum - for Porsche Boxster & Cayman Owners > Porsche Boxster & Cayman Forums > Boxster General Discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 07-07-2007, 09:10 AM   #1
Registered User
 
Join Date: Mar 2007
Location: Beaverton Oregon
Posts: 6
Talking Top stopped working.

I have a 98 Boxster and a couple of days ago I went to put the top down and it would not work. It had been working fine that same morning.

When I release the latch at roof line the windows drop about a third of the way down as they should. When I push the button absolutely nothing happens.

The car is not in gear and the brake is on and the dashboard light shows that the break is on. I checked the fuses and they look fine.

Where do I go from here and in what order? Any advice would be greatly appreciated.

Randy Arnold is offline   Reply With Quote
Old 07-07-2007, 10:02 AM   #2
Registered User
 
Join Date: Apr 2007
Location: san fran
Posts: 241
wow never thought i would see someone with a happy face icon whose top didn't work....lol....if the windows drop then i would check the switch first....then motor...hope all work out...mike
mikes_box is offline   Reply With Quote
Old 07-07-2007, 12:19 PM   #3
Registered User
 
Join Date: Dec 2006
Location: South Carolina
Posts: 456
Just went through a top not working nightmare. Anyway , make sure the connection for the handbrake is good. Do you get a brief sound from the top motor when you press the button? If so your switch should be ok, but start with those.

After that, you need to manually lower the top which requires taking off two control arms from the clam shell. There is a motor mounted on the trunk wall. You can pull the cable out from both sides. You should have about 3/4" cable showing on each end. Sometimes the housing stretches and the motor essentially does not have enough cable to grab.

That would be the easiest things to hope is wrong. I got alot of help and a great checklist how to with pics on Renntech.org.

Good luck!
__________________
http://i122.photobucket.com/albums/o...986/986sig.jpg
2002 Boxster S
SC986 is offline   Reply With Quote
Old 07-07-2007, 08:54 PM   #4
Registered User
 
Join Date: Mar 2007
Location: Beaverton Oregon
Posts: 6
Talking Fixed

I got lucky. I took the switch out and apart and a small piece of plastic was preventing the connection. I cleaned it out and it is fine now.

Thank you for your advice.

Randy Arnold is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 08:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page