986 Forum - for Porsche Boxster & Cayman Owners

986 Forum - for Porsche Boxster & Cayman Owners (http://986forum.com/forums/)
-   Performance and Technical chat (http://986forum.com/forums/performance-technical-chat/)
-   -   Engine Mounts (http://986forum.com/forums/performance-technical-chat/5068-engine-mounts.html)

BoxsterRS 02-11-2006 08:38 PM

Engine Mounts
 
Has anyone changed their engine mounts or got them changed by the dealer. I live in PR and over here its more like a do it your self, cause dealers are too crapy and you have to wait weeks even months before you get your car done. My Dad and I work every car we have but we wanted to keep my car in oem condition and done by trained people. Iwas told this was difficult due to the engine location. If anyone has had this done or know anything please reply or send me an e-mail at sergiorortiz@gmail.com If its not related to the question please don't use this e-mail adress for anything else!!! Hope to get some replies soon!!!!

socratic 02-12-2006 11:06 AM

What is the purpose of changing an engine mount?

BoxsterRS 02-13-2006 03:38 PM

The engine mounts are what hold engine and dampen engine moving when accelerating. On renntech.org I found another guy that changed his mounts on his 98. Also found that 98 boxster had a rubber bushing that wore out quickly. Everytime I accelerate hard it makes sort of a clunk noise that comes from the engine. If there is anyone with a lot of knowledge about this matter please do so and correct me. Also, would it be better to upgrade mounts to polyurethane or buy new 03spec and up mounts that fix this problem by adding a metal plate at the end of each side of the rubber?

MNBoxster 02-13-2006 04:46 PM

Quote:

Originally Posted by BoxsterRS
The engine mounts are what hold engine and dampen engine moving when accelerating. On renntech.org I found another guy that changed his mounts on his 98. Also found that 98 boxster had a rubber bushing that wore out quickly. Everytime I accelerate hard it makes sort of a clunk noise that comes from the engine. If there is anyone with a lot of knowledge about this matter please do so and correct me. Also, would it be better to upgrade mounts to polyurethane or buy new 03spec and up mounts that fix this problem by adding a metal plate at the end of each side of the rubber?

Hi,

The first thing you need to do is verify that it's the Mounts. These are Mucho Expensive and so you don't want to replace them needlessly.

Get the Car on a lift and startit and rev the motor all the while looking at it from underneath for excess movement. It could just as easily be a loose Exhaust Mount or Heat shield causing the problem.

Also, stay with OEM. Poly Bushings (if available) will not be reliliant enough and will make the shutter harsher and be much noisier too.

Happy Motoring!... Jim'99

JaysPcar 11-04-2007 10:44 AM

I had this question before and currently working on mine. View the link and you will find another link for the install.

http://986forum.com/forums/boxster-general-discussions/13812-technolab-remanufactured-mounts.html


All times are GMT -8. The time now is 06:03 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website