986 Forum - for Porsche Boxster & Cayman Owners

986 Forum - for Porsche Boxster & Cayman Owners (http://986forum.com/forums/)
-   Boxster General Discussions (http://986forum.com/forums/boxster-general-discussions/)
-   -   Car towed again- ugly grinding/whirring noise and water leaking all over floor (http://986forum.com/forums/boxster-general-discussions/29374-car-towed-again-ugly-grinding-whirring-noise-water-leaking-all-over-floor.html)

ASpec818 06-19-2011 07:54 PM

Car towed again- ugly grinding/whirring noise and water leaking all over floor
 
I was driving normally and downshifted coming to a stop on a downhill. I heard a loud whirring noise upon deceleration. Drove a few more blocks off the road into a mall parking lot and there was more ugly whirring / grinding noise when decelerating. Then the charging light came on and the car barely wanted to move. I parked it and there was smoke spewing and light brown liquid leaking all over the floor. Any idea on what is going on? I hope I didn't cause extensive damage to the car for driving it another 3 blocks.

The consistency of the light brown liquid feels slightly lighter than motor oil... Can it be coolant?

Jager 06-19-2011 08:18 PM

Coolant is pinkish in color, if it's been serviced regularly. Motor oil is very thin when it's warm, could it be motor oil? If the two get mixed together the fluid is a light brown color (caramel color) and less transparent.

ASpec818 06-19-2011 09:10 PM

I take that back. It's probably motor oil that leaked all over the floor. Can someone PLEASE tell me it's not an IMS failure? Are the symptoms of a failure similar to mine?

ASpec818 06-19-2011 09:16 PM

I take that back. It's probably motor oil that leaked all over the floor. Can someone PLEASE tell me it's not an IMS failure? Are the symptoms of a failure similar to mine?

sasha055 06-19-2011 09:17 PM

It could be Power steering fluid
It happend to me in parking. Power steering hose broke, light brownish fluid all over the floor, and without fluid power steering pump make an ugly grinding noise.

Check your steering fluid level, as well as coolant level (in case it's a waterpump or coolant tank)..

Sasha

ASpec818 06-19-2011 09:40 PM

Quote:

Originally Posted by sasha055
It could be Power steering fluid
It happend to me in parking. Power steering hose broke, light brownish fluid all over the floor, and without fluid power steering pump make an ugly grinding noise.

Check your steering fluid level, as well as coolant level (in case it's a waterpump or coolant tank)..

Sasha

I have my fingers crossed and hope this is the case. I can't check the level right now since the car is sitting outside the shop. Will the charging light come on if the power steering pump fails? The steering wheel was still turning fine.

I'm not sure is it engine oil because it wasn't as thick but was the same clearish brown color. It was liked watered down motor oil.

Also, for IMS failures, does ALL the oil leak out or just a some of it? The electronic oil level gauge read the same when I turned the key...

san rensho 06-20-2011 04:02 AM

Water pump. The plastic impeller broke up into many fragments so try to account for all the broken pieces to make sure no little bits got into the tiny coolant passages in the head which can lead to localized overheating and cracking of the head.

Topless 06-20-2011 06:16 AM

Step 1. Figure out what it is and where it came from. Is it coolant, oil, clutch fluid, brake fluid, power steering fluid? Where is it coming from? Front of the car, middle, rear of the car, drivers side, pass side? When you pull the dip stick what do you see? When you open the coolant tank what do you see?

ASpec818 06-20-2011 01:16 PM

Quote:

Originally Posted by san rensho
Water pump. The plastic impeller broke up into many fragments so try to account for all the broken pieces to make sure no little bits got into the tiny coolant passages in the head which can lead to localized overheating and cracking of the head.


san rensho, you're on point. just got a call from the mechanic and he said it was the pump. He recommends oem only on this part because they're weak to begin with. Cost difference seems to be about $120 between oem and aftermarket. Is it worth saving $120 for aftermaket? He also recommended a new belt for $45.
Although it's a repair, I'm just glad it wasn't anything major.

san rensho 06-20-2011 05:42 PM

I just did my waterpump and motor mount this weekend and I went with the OEM part, but i have an in with the parts guy at the dealership and he gives me parts at a discount. I ended up paying for an OEM what Pelican charges for a Laso pump, so it was a no brainer with me.

san rensho 06-21-2011 07:06 AM

Quote:

Originally Posted by ASpec818
san rensho, you're on point. just got a call from the mechanic and he said it was the pump. He recommends oem only on this part because they're weak to begin with. Cost difference seems to be about $120 between oem and aftermarket. Is it worth saving $120 for aftermaket? He also recommended a new belt for $45.
Although it's a repair, I'm just glad it wasn't anything major.


How much is he charging you for labor?

ASpec818 06-21-2011 07:09 AM

Quote:

Originally Posted by san rensho
How much is he charging you for labor?

about $260 for labor. i think that's in par with most water pump replacements right?

san rensho 06-21-2011 07:13 AM

Quote:

Originally Posted by ASpec818
about $260 for labor. i think that's in par with most water pump replacements right?


Sounds fair.


All times are GMT -8. The time now is 10:18 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website